发布时间 :2004-02-17 00:00:00
修订时间 :2016-10-17 22:40:34

[原文]PHP remote file inclusion vulnerability in module.php for ezContents allows remote attackers to execute arbitrary PHP code by modifying the link parameter to reference a URL on a remote web server that contains the code.

[CNNVD]VisualShapers EZContents module.php远程命令执行漏洞(CNNVD-200402-063)

        VisualShapers ezContents是一款基于PHP和MYSQL的WEB站点内容管理系统。
        VisualShapers ezContents包含的module.php脚本对外部提交输入缺少充分过滤,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040110 Remote Code Execution in ezContents
(UNKNOWN)  XF  ezcontents-php-file-include(14199)

- 漏洞信息

VisualShapers EZContents module.php远程命令执行漏洞
高危 未知
2004-02-17 00:00:00 2006-11-02 00:00:00
        VisualShapers ezContents是一款基于PHP和MYSQL的WEB站点内容管理系统。
        VisualShapers ezContents包含的module.php脚本对外部提交输入缺少充分过滤,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。

- 公告与补丁


- 漏洞信息 (23537)

VisualShapers EZContents 1.4/2.0 Module.PHP Remote Command Execution Vulnerability (EDBID:23537)
php webapps
2004-01-10 Verified
0 Zero X
N/A [点击下载]

A problem in handling of specific types of input passed to the module.php script in VisualShapers ezContents has been discovered. Because of this, an attacker may be able to gain unauthorized access to vulnerable systems. /etc/passwd		

- 漏洞信息

ezContents module.php Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ezContents contains a flaw that allows a remote attacker to execute arbitrary commands. This flaw exists because the application does not validate the "link" parameter upon submission to the "modules.php" script. By sending a specially crafted URL which specifies a malicious file from a remote system, a remote attacker could execute arbitrary commands, resulting in a loss of integrity.

- 时间线

2004-01-10 Unknow
2004-01-10 Unknow

- 解决方案

Upgrade to version 2.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者