CVE-2004-0067
CVSS4.3
发布时间 :2004-02-17 00:00:00
修订时间 :2016-10-17 22:40:30
NMCOES    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in phpGedView before 2.65 allow remote attackers to inject arbitrary HTML or web script via (1) descendancy.php, (2) index.php, (3) individual.php, (4) login.php, (5) relationship.php, (6) source.php, (7) imageview.php, (8) calendar.php, (9) gedrecord.php, (10) login.php, and (11) gdbi_interface.php. NOTE: some aspects of vector 10 were later reported to affect 4.1.


[CNNVD]PhpGedView Index.PHP跨站脚本漏洞(CNNVD-200402-056)

        phpGedView 2.65之前版本存在多个跨站脚本漏洞。远程攻击者可以借助(1) descendancy.php, (2) index.php, (3) individual.php, (4) login.php, (5) relationship.php, (6) source.php, (7) imageview.php, (8) calendar.php, (9) gedrecord.php, (10) login.php以及(11) gdbi_interface.php注入任意HTML或者web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0067
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0067
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200402-056
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107394912715478&w=2
(UNKNOWN)  BUGTRAQ  20040112 More phpGedView Vulnerabilities
http://securitytracker.com/id?1018613
(UNKNOWN)  SECTRACK  1018613
http://www.securityfocus.com/archive/1/archive/1/477881/100/0/threaded
(UNKNOWN)  BUGTRAQ  20070827 PhpGedView login page multiple XSS
http://www.securityfocus.com/bid/11868
(UNKNOWN)  BID  11868
http://www.securityfocus.com/bid/11880
(UNKNOWN)  BID  11880
http://www.securityfocus.com/bid/11882
(UNKNOWN)  BID  11882
http://www.securityfocus.com/bid/11888
(UNKNOWN)  BID  11888
http://www.securityfocus.com/bid/11890
(UNKNOWN)  BID  11890
http://www.securityfocus.com/bid/11891
(UNKNOWN)  BID  11891
http://www.securityfocus.com/bid/11894
(UNKNOWN)  BID  11894
http://www.securityfocus.com/bid/11903
(UNKNOWN)  BID  11903
http://www.securityfocus.com/bid/11904
(UNKNOWN)  BID  11904
http://www.securityfocus.com/bid/11905
(UNKNOWN)  BID  11905
http://www.securityfocus.com/bid/11906
(UNKNOWN)  BID  11906
http://www.securityfocus.com/bid/11907
(UNKNOWN)  BID  11907
http://www.vupen.com/english/advisories/2007/2995
(VENDOR_ADVISORY)  VUPEN  ADV-2007-2995
http://xforce.iss.net/xforce/xfdb/14212
(UNKNOWN)  XF  phpgedview-multiple-xss(14212)
http://xforce.iss.net/xforce/xfdb/36285
(UNKNOWN)  XF  phpgedview-login-xss(36285)

- 漏洞信息

PhpGedView Index.PHP跨站脚本漏洞
中危 跨站脚本
2004-02-17 00:00:00 2009-01-29 00:00:00
远程  
        phpGedView 2.65之前版本存在多个跨站脚本漏洞。远程攻击者可以借助(1) descendancy.php, (2) index.php, (3) individual.php, (4) login.php, (5) relationship.php, (6) source.php, (7) imageview.php, (8) calendar.php, (9) gedrecord.php, (10) login.php以及(11) gdbi_interface.php注入任意HTML或者web脚本。

- 公告与补丁

        The vendor has addressed this issue in PhpGedView 2.65 and later.
        PhpGedView PhpGedView 2.52.3
        
        PhpGedView PhpGedView 2.60
        
        PhpGedView PhpGedView 2.61
        
        PhpGedView PhpGedView 2.61.1
        
        PhpGedView PhpGedView 2.65 beta5
        

- 漏洞信息 (24810)

PhpGedView 2.x Descendancy.PHP Cross-Site Scripting Vulnerability (EDBID:24810)
php webapps
2004-01-19 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11868/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/descendancy.php?pid=<iframe>		

- 漏洞信息 (24814)

PhpGedView 2.5/2.6 Index.PHP Cross-Site Scripting Vulnerability (EDBID:24814)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11880/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/index.php?rootid="><iframe>		

- 漏洞信息 (24816)

PhpGedView 2.5/2.6 Individual.PHP Cross-Site Scripting Vulnerability (EDBID:24816)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11882/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/individual.php?pid="><iframe>		

- 漏洞信息 (24819)

PhpGedView 2.5/2.6 Source.PHP Cross-Site Scripting Vulnerability (EDBID:24819)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11888/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/source.php?sid=<iframe>		

- 漏洞信息 (24820)

PhpGedView 2.5/2.6 Imageview.PHP Cross-Site Scripting Vulnerability (EDBID:24820)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11890/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/imageview.php?filename=<iframe>		

- 漏洞信息 (24821)

PhpGedView 2.5/2.6 Gedrecord.PHP Cross-Site Scripting Vulnerability (EDBID:24821)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11891/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/gedrecord.php?pid=<iframe>		

- 漏洞信息 (24822)

PhpGedView 2.5/2.6 Gdbi_interface.PHP Cross-Site Scripting Vulnerability (EDBID:24822)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11894/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/gdbi_interface.php?action=delete&pid=<iframe>		

- 漏洞信息 (24829)

PhpGedView 2.5/2.6 Login.PHP URL Parameter Cross-Site Scripting Vulnerability (EDBID:24829)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11903/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/login.php?url=/index.php?GEDCOM="><iframe>		

- 漏洞信息 (24830)

PhpGedView 2.5/2.6 Login.PHP Username Parameter Cross-Site Scripting Vulnerability (EDBID:24830)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11904/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/login.php?action=login&username="><iframe>		

- 漏洞信息 (24831)

PhpGedView 2.5/2.6 Login.PHP Newlanguage Cross-Site Scripting Vulnerability (EDBID:24831)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11905/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.
 
This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/login.php?&changelanguage=yes&NEWLANGUAGE=<iframe>		

- 漏洞信息 (24832)

PhpGedView 2.5/2.6 Relationship.PHP Cross-Site Scripting Vulnerability (EDBID:24832)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11906/info
 
It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/relationship.php?path_to_find="><iframe>
http://www.example.com/phpgedview/relationship.php?path_to_find=0&pid1="><iframe>
http://www.example.com/phpgedview/relationship.php?path_to_find=0&pid1=&pid2="><iframe>
		

- 漏洞信息 (24834)

PhpGedView 2.5/2.6 Calendar.PHP Cross-Site Scripting Vulnerability (EDBID:24834)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11907/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/calendar.php?action=today&day=1&month=jan&year="><iframe>
http://www.example.com/phpgedview/calendar.php?action=today&day=1&month=<iframe>
http://www.example.com/phpgedview/calendar.php?action=today&day=<iframe>		

- 漏洞信息 (24835)

PhpGedView 2.5/2.6 Placelist.PHP SQL Injection Vulnerability (EDBID:24835)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11910/info

It is reported that PhpGedView is susceptible to a remote SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input prior to including it in an SQL query.

This issue allows remote attackers to manipulate query logic, leading to unauthorized access and the disclosure of potentially sensitive information. The issue also allows the possible corruption of database data leading to a loss of integrity. SQL injection attacks may also be used to exploit latent vulnerabilities in the underlying database.

This issue has been reported to effect PhpGedView 2.65beta5 and earlier.

http://www.example.com/phpgedview/placelist.php?level=1[Evil_Query]
http://www.example.com/phpgedview/placelist.php?level=1&parent[0]=[Evil_Query]
http://www.example.com/phpgedview/placelist.php?level=2&parent[0]=&parent[1]=[Evil_Query]		

- 漏洞信息 (24837)

PhpGedView 2.5/2.6 Timeline.PHP SQL Injection Vulnerability (EDBID:24837)
php webapps
2004-01-12 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/11925/info

It is reported that PhpGedView is susceptible to a remote SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input prior to including it in an SQL query.

This issue allows remote attackers to manipulate query logic. The issue could theoretically be exploited to compromise the software by performing unauthorized actions on the database, such as modifying or viewing data. SQL injection attacks may also be used to exploit latent vulnerabilities in the underlying database. This may depend on the nature of the query being manipulated as well as the capabilities of the database implementation.

This issue has been reported to effect PhpGedView 2.65beta5 and earlier.

http://www.example.com/phpgedview/timeline.php?pids=[Evil_Query]		

- 漏洞信息

3473
PhpGedView gdbi_interface.php pid Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PhpGedView contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'pid' variables upon submission to the 'gdbi_interface.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-12 Unknow
2004-01-12 Unknow

- 解决方案

Upgrade to version 2.65 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PhpGedView Calendar.PHP Cross-Site Scripting Vulnerability
Input Validation Error 11907
Yes No
2004-01-12 12:00:00 2009-07-12 05:56:00
Discovery of this vulnerability is credited to JeiAr <security@gulftech.org>.

- 受影响的程序版本

PhpGedView PhpGedView 2.65 beta5
PhpGedView PhpGedView 2.61.1
PhpGedView PhpGedView 2.61
PhpGedView PhpGedView 2.60
PhpGedView PhpGedView 2.52.3
PhpGedView PhpGedView 2.65

- 不受影响的程序版本

PhpGedView PhpGedView 2.65

- 漏洞讨论

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

- 漏洞利用

No exploit is required and the following proof of concepts are available:

http://www.example.com/phpgedview/calendar.php?action=today&amp;day=1&amp;month=jan&amp;year="&gt;&lt;iframe&gt;
http://www.example.com/phpgedview/calendar.php?action=today&amp;day=1&amp;month=&lt;iframe&gt;
http://www.example.com/phpgedview/calendar.php?action=today&amp;day=&lt;iframe&gt;

- 解决方案

The vendor has addressed this issue in PhpGedView 2.65 and later.


PhpGedView PhpGedView 2.52.3

PhpGedView PhpGedView 2.60

PhpGedView PhpGedView 2.61

PhpGedView PhpGedView 2.61.1

PhpGedView PhpGedView 2.65 beta5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站