CVE-2004-0041
CVSS7.5
发布时间 :2004-02-03 00:00:00
修订时间 :2008-09-05 16:37:20
NMCOS    

[原文]The mod_auth_shadow module 1.4 and earlier does not properly enforce the expiration of a user account and password, which could allow remote authenticated users to bypass intended access restrictions.


[CNNVD]Mod-Auth-Shadow Apache模块终止用户验证失败漏洞(CNNVD-200402-015)

        
        mod-auth-shadow是一款Apache模块,可通过系统shadow密码数据库对用户进行验证。
        mod-auth-shadow对过期或终止状态的用户帐户和密码没有进行正确限制验证,远程攻击者可以利用这些帐户绕过验证访问受限资源。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:mod_auth_shadow:mod_auth_shadow:1.2
cpe:/a:mod_auth_shadow:mod_auth_shadow:1.3
cpe:/a:mod_auth_shadow:mod_auth_shadow:1.4
cpe:/a:mod_auth_shadow:mod_auth_shadow:1.1
cpe:/a:mod_auth_shadow:mod_auth_shadow:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0041
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0041
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200402-015
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2004/dsa-421
(VENDOR_ADVISORY)  DEBIAN  DSA-421
http://www.securitytracker.com/id?1008675
(UNKNOWN)  SECTRACK  1008675
http://www.securityfocus.com/bid/9404
(VENDOR_ADVISORY)  BID  9404
http://www.osvdb.org/3454
(UNKNOWN)  OSVDB  3454
http://secunia.com/advisories/10612
(VENDOR_ADVISORY)  SECUNIA  10612

- 漏洞信息

Mod-Auth-Shadow Apache模块终止用户验证失败漏洞
高危 设计错误
2004-02-03 00:00:00 2005-10-20 00:00:00
远程  
        
        mod-auth-shadow是一款Apache模块,可通过系统shadow密码数据库对用户进行验证。
        mod-auth-shadow对过期或终止状态的用户帐户和密码没有进行正确限制验证,远程攻击者可以利用这些帐户绕过验证访问受限资源。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-421

- 漏洞信息

3454
mod_auth_shadow Account Expiry Date Not Enforced

- 漏洞描述

mod_auth_shadow contains a flaw that may allow a malicious user to log in with an expired account. The issue is triggered because mod_auth_shadow doesn't check for account expiration. It is possible that the flaw may allow an attacker to log in with an expired account resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-01-07 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Mod-Auth-Shadow Apache Module Expired User Credential Weakness
Design Error 9404
Yes No
2004-01-12 12:00:00 2009-07-12 05:56:00
Discovery credited to David B Harris.

- 受影响的程序版本

mod_auth_shadow mod_auth_shadow 1.3
mod_auth_shadow mod_auth_shadow 1.2
mod_auth_shadow mod_auth_shadow 1.1
mod_auth_shadow mod_auth_shadow 1.0
mod_auth_shadow mod_auth_shadow 1.4

- 不受影响的程序版本

mod_auth_shadow mod_auth_shadow 1.4

- 漏洞讨论

A problem has been identified in mod-auth-shadow that may permit a user to gain access to a web site after the expiration of their credentials. This weakness may result in users gaining access to the web site outside of the period of validity for their credentials.

- 漏洞利用

No exploit is required.

- 解决方案

Debian has released advisory DSA 421-1 to address this issue.


mod_auth_shadow mod_auth_shadow 1.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站