CVE-2004-0038
CVSS7.5
发布时间 :2004-06-14 00:00:00
修订时间 :2008-09-05 16:37:20
NMCOS    

[原文]McAfee ePolicy Orchestrator (ePO) 2.5.1 Patch 13 and 3.0 SP2a Patch 3 allows remote attackers to execute arbitrary commands via certain HTTP POST requests to the spipe/file handler on ePO TCP port 81.


[CNNVD]McAfee ePolicy Orchestrator未明远程命令执行漏洞(CNNVD-200406-043)

        
        McAfee Security ePolicy Orchestrator是一款企业级反病毒管理工具。
        ePolicy Orchestrator存在未明命令执行漏洞,远程攻击者可以利用这个漏洞以进程权限在系统上执行任意命令,控制系统。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mcafee:epolicy_orchestrator:3.0McAfee ePolicy Orchestrator 3.0
cpe:/a:mcafee:epolicy_orchestrator:2.5.1McAfee ePolicy Orchestrator 2.5.1
cpe:/a:mcafee:epolicy_orchestrator:2.5:sp1McAfee ePolicy Orchestrator 2.5 SP1
cpe:/a:mcafee:epolicy_orchestrator:2.5McAfee ePolicy Orchestrator 2.5
cpe:/a:mcafee:epolicy_orchestrator:3.0:sp2aMcAfee ePolicy Orchestrator 3.0 service pack 2a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0038
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0038
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200406-043
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/14166
(VENDOR_ADVISORY)  XF  epolicy-execute-commands(14166)
http://xforce.iss.net/xforce/alerts/id/173
(VENDOR_ADVISORY)  ISS  20040510 McAfee ePolicy Orchestrator Remote Compromise Vulnerability
http://www.securityfocus.com/bid/10200
(VENDOR_ADVISORY)  BID  10200
http://www.osvdb.org/5626
(VENDOR_ADVISORY)  MISC  http://www.osvdb.org/5626
http://download.nai.com/products/patches/ePO/v2.x/Patch14.txt
(VENDOR_ADVISORY)  CONFIRM  http://download.nai.com/products/patches/ePO/v2.x/Patch14.txt

- 漏洞信息

McAfee ePolicy Orchestrator未明远程命令执行漏洞
高危 其他
2004-06-14 00:00:00 2005-10-20 00:00:00
远程  
        
        McAfee Security ePolicy Orchestrator是一款企业级反病毒管理工具。
        ePolicy Orchestrator存在未明命令执行漏洞,远程攻击者可以利用这个漏洞以进程权限在系统上执行任意命令,控制系统。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        McAfee
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        McAfee ePolicy Orchestrator 2.5.1:
        McAfee Upgrade EPO25114.zip
        
        http://download.nai.com/products/patches/ePO/v2.x/EPO25114.zip

        McAfee ePolicy Orchestrator 3.0 SP2a:
        McAfee Upgrade EPO3024.ZIP
        
        http://download.nai.com/products/patches/ePO/v3.0/EPO3024.ZIP

- 漏洞信息

5626
McAfee ePolicy Orchestrator HTTP POST spipe/file Handler Arbitrary File Creation
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

McAfee ePolicy Orchestrator contains a flaw that may allow a malicious user to execute arbitrary code with system privileges. The flaw is due to the server not properly sanitizing HTTP POST requests. If an attacker supplies a specially crafted request, they may be able to create arbitrary files. With the right files, it is possible to create an installation package that would be executed under some circumstances, allowing arbitrary commands and files to be run with the privileges of the ePo server.

- 时间线

2004-04-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.5.1 Patch 14 or higher or 3.0 SP2a Patch 4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

McAfee ePolicy Orchestrator Server Remote Code Execution Vulnerability
Failure to Handle Exceptional Conditions 10200
Yes No
2004-04-23 12:00:00 2009-07-12 04:06:00
Discovery of this vulnerability has been credited to Internet Security Systems.

- 受影响的程序版本

McAfee ePolicy Orchestrator 3.0 SP2a
McAfee ePolicy Orchestrator 3.0
McAfee ePolicy Orchestrator 2.5.1
McAfee ePolicy Orchestrator 2.5 SP1
McAfee ePolicy Orchestrator 2.5

- 漏洞讨论

McAfee ePolicy Orchestrator has been reported prone to a remote code execution vulnerability. The issue is reported to be triggered when certain HTTP POST requests are handled by the McAfee ePolicy Orchestrator server.

An attacker may exploit this issue to execute code in the context of the affected software, and distribute this code across ePolicy Orchestrator infrastructure.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released a patch to address this issue:


McAfee ePolicy Orchestrator 2.5.1

McAfee ePolicy Orchestrator 3.0 SP2a

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站