发布时间 :2004-01-20 00:00:00
修订时间 :2016-10-17 22:39:58

[原文]Cross-site scripting (XSS) vulnerability in search.php in PHPGEDVIEW 2.61 allows remote attackers to inject arbitrary HTML and web script via the firstname parameter.

[CNNVD]PhpGedView Search Script跨站脚本漏洞(CNNVD-200401-048)

        PHPGEDVIEW 2.61版本的search.php存在跨站脚本漏洞。远程攻击者借助firstname参数注入任意HTML以及web脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040106 Vuln in PHPGEDVIEW 2.61 Multi-Problem
(UNKNOWN)  BID  9369
(VENDOR_ADVISORY)  XF  phpgedview-search-xss(14160)

- 漏洞信息

PhpGedView Search Script跨站脚本漏洞
中危 跨站脚本
2004-01-20 00:00:00 2005-09-02 00:00:00
        PHPGEDVIEW 2.61版本的search.php存在跨站脚本漏洞。远程攻击者借助firstname参数注入任意HTML以及web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (23525)

PhpGedView 2.61 Search Script Cross-Site Scripting Vulnerability (EDBID:23525)
php webapps
2004-01-06 Verified
0 Windak
N/A [点击下载]

PhpGedView is prone to a cross-site scripting vulnerability. Remote attackers may create malicious links to this script that include hostile HTML and script code. If such a link was followed by a victim user, the attacker-supplied code would be rendered in the security context of the site hosting the software.

This could be exploited to steal cookie-based authentication credentials. Other attacks are also possible.

This issue is reported to affect PhpGedView 2.61. Other versions are also likely affected.


- 漏洞信息

PhpGedView search.php XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

PhpGedView contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate "firstname" variables upon submission to the search.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-06 2004-01-06
Unknow Unknow

- 解决方案

Upgrade to version 2.65 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. Note that 2.65 is currently only available as a beta release.

- 相关参考

- 漏洞作者

Unknown or Incomplete