CVE-2004-0017
CVSS7.5
发布时间 :2004-02-03 00:00:00
修订时间 :2008-09-05 16:37:18
NMCOS    

[原文]Multiple SQL injection vulnerabilities in the (1) calendar and (2) infolog modules for phpgroupware 0.9.14 allow remote attackers to perform unauthorized database operations.


[CNNVD]PHPGroupWare多个SQL注入漏洞(CNNVD-200402-009)

        
        PHPGroupware是一款免费开放源代码的群件系统,由PHPGroupware项目组开发维护并通过PHP语言实现。
        PHPGroupWare包含的'calendar'和'infolog'模块存在SQL注入漏洞,远程攻击者可以利用这个漏洞获得敏感信息或进行数据库修改。
        问题是'calendar'和'infolog'模块对外部输入缺少充分过滤,提交恶意SQL命令作为URI参数,可更改原有的数据库逻辑,获得敏感信息或进行数据库修改。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0017
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0017
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200402-009
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2004/dsa-419
(VENDOR_ADVISORY)  DEBIAN  DSA-419
http://www.securityfocus.com/bid/9386
(VENDOR_ADVISORY)  BID  9386
http://www.securitytracker.com/id?1008662
(UNKNOWN)  SECTRACK  1008662
http://secunia.com/advisories/10591
(UNKNOWN)  SECUNIA  10591

- 漏洞信息

PHPGroupWare多个SQL注入漏洞
高危 输入验证
2004-02-03 00:00:00 2005-10-20 00:00:00
远程  
        
        PHPGroupware是一款免费开放源代码的群件系统,由PHPGroupware项目组开发维护并通过PHP语言实现。
        PHPGroupWare包含的'calendar'和'infolog'模块存在SQL注入漏洞,远程攻击者可以利用这个漏洞获得敏感信息或进行数据库修改。
        问题是'calendar'和'infolog'模块对外部输入缺少充分过滤,提交恶意SQL命令作为URI参数,可更改原有的数据库逻辑,获得敏感信息或进行数据库修改。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-419

- 漏洞信息

2691
phpGroupWare Calendar Module SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

phpGroupWare contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that variables in the 'calendar' module are not verified properly and will allow an attacker to inject or manipulate SQL queries. No further details have been provided.

- 时间线

2003-10-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.14.007 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPGroupWare Multiple Module SQL Injection Vulnerabilities
Input Validation Error 9386
Yes No
2004-01-09 12:00:00 2009-07-12 12:56:00
The disclosure of these issues has been credited to the vendor.

- 受影响的程序版本

PHPGroupWare PHPGroupWare 0.9.16 RC1
PHPGroupWare PHPGroupWare 0.9.14 .006
PHPGroupWare PHPGroupWare 0.9.14 .005
- Conectiva Linux 9.0
- Conectiva Linux 8.0
- Conectiva Linux 7.0
PHPGroupWare PHPGroupWare 0.9.14 .003
PHPGroupWare PHPGroupWare 0.9.14 .007

- 不受影响的程序版本

PHPGroupWare PHPGroupWare 0.9.14 .007

- 漏洞讨论

It has been reported that PHPGroupWare may be prone to multiple SQL injection vulnerabilities in the 'calendar' and 'infolog' modules. The problems exist due to insufficient sanitization of user-supplied data. A remote attacker may exploit these issues to influence SQL query logic to disclose sensitive information that could be used to gain unauthorized access.

PHPGroupWare versions 0.9.14.006, 0.9.16 RC1, and prior may be prone to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released version 0.9.14.007 of the software to address this and other issues. Users are also advised to download a fixed version of the RC1 release from the vendor.

Debian has released an advisory DSA-419-1 to address this issue. Please see the referenced advisory for more information.


PHPGroupWare PHPGroupWare 0.9.14 .003

PHPGroupWare PHPGroupWare 0.9.14 .006

PHPGroupWare PHPGroupWare 0.9.14 .005

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站