发布时间 :2014-10-01 10:55:08
修订时间 :2014-10-02 11:47:05

[原文]SQL injection vulnerability in log.header.php in WordPress 0.7 and earlier allows remote attackers to execute arbitrary SQL commands via the posts variable.

[CNNVD]WordPress SQL注入漏洞(CNNVD-201410-001)



WordPress 0.7及之前版本的log.header.php脚本存在SQL注入漏洞。远程攻击者可借助‘posts’变量利用该漏洞执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  wordpress-blogheader-sql-injection(12204)
(UNKNOWN)  BID  7784
(UNKNOWN)  MLIST  [oss-sec] 20120106 Re: CVE-request: WordPress SQL injection and arbitrary code injection (2003)

- 漏洞信息

WordPress SQL注入漏洞
高危 SQL注入
2014-10-10 00:00:00 2014-10-10 00:00:00


WordPress 0.7及之前版本的log.header.php脚本存在SQL注入漏洞。远程攻击者可借助‘posts’变量利用该漏洞执行任意SQL命令。

- 公告与补丁


- 漏洞信息

WordPress blog.header.php posts Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

WordPress contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the "posts" variable in the "blog.header.php" module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2003-06-02 Unknow
2003-06-02 Unknow

- 解决方案

Upgrade to version 0.72 RC1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Wordpress Posts SQL Injection Vulnerability
Input Validation Error 7784
Yes No
2003-06-02 12:00:00 2012-01-06 10:00:00
Discovery of this vulnerability has been credited to

- 受影响的程序版本

WordPress WordPress 0.7

- 漏洞讨论

Wordpress has been reported prone to an SQL injection vulnerability.

Wordpress does not properly sanitize user input that is passed to the 'posts' variable. An attacker may exploit this issue to insert SQL code into requests and have the SQL code executed by the underlying database server.

It should be noted that although this vulnerability has been reported to affect Wordpress version 0.7, other versions might also be affected.

- 漏洞利用

This vulnerability may be exploiting using a web browser.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考