CVE-2003-1573
CVSS10.0
发布时间 :2009-06-01 18:30:00
修订时间 :2009-06-02 00:00:00
NMCO    

[原文]The PointBase 4.6 database component in the J2EE 1.4 reference implementation (J2EE/RI) allows remote attackers to execute arbitrary programs, conduct a denial of service, and obtain sensitive information via a crafted SQL statement, related to "inadequate security settings and library bugs in sun.* and org.apache.* packages."


[CNNVD]Sun J2EE/RI Pointbase数据库远程命令执行漏洞(CNNVD-200906-005)

        J2EE/RI Pointbase是一个纯JAVA数据库,可以方便的开发JAVA产品 。
        J2EE/RI (Reference Implementation) Pointbase数据库存在安全问题,远程攻击者可以利用这个漏洞通过jdbc插入任意代码或对数据库进行拒绝服务攻击 。
        通过使用特殊构建的SQL命令可导致在运行pointbase数据库的主机上执行任意代码。问题是由于jdk 1.4.2_02中的sun.*和org.apache.*库中漏洞及不充分的安全设置导致。利用这些漏洞也可能使攻击者对数据库进行拒绝服务攻击 。
        目前没有详细的漏洞细节提供 。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1573
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1573
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200906-005
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/14008
(PATCH)  XF  j2ee-pointbase-sql-injection(14008)
http://xforce.iss.net/xforce/xfdb/14883
(UNKNOWN)  XF  pointbase-command-execution(14883)
http://xforce.iss.net/xforce/xfdb/14882
(UNKNOWN)  XF  pointbase-information-disclosure(14882)
http://xforce.iss.net/xforce/xfdb/14881
(UNKNOWN)  XF  pointbase-insecure-permissions-dos(14881)
http://www.securityfocus.com/bid/9230
(UNKNOWN)  BID  9230
http://securitytracker.com/id?1008491
(UNKNOWN)  SECTRACK  1008491
http://secunia.com/advisories/10460
(VENDOR_ADVISORY)  SECUNIA  10460
http://seclists.org/bugtraq/2003/Dec/0249.html
(UNKNOWN)  BUGTRAQ  20031216 J2EE 1.4 reference implementation: database component allows remote code execution
http://archives.neohapsis.com/archives/fulldisclosure/2004-01/0675.html
(UNKNOWN)  FULLDISC  20040118 Proof-Of-Concept Denial-Of-Service Pointbase 4.6 Java SQL-DB
http://archives.neohapsis.com/archives/bugtraq/2004-01/0148.html
(UNKNOWN)  BUGTRAQ  20040118 Proof-Of-Concept Denial-Of-Service Pointbase 4.6 Java SQL-DB

- 漏洞信息

Sun J2EE/RI Pointbase数据库远程命令执行漏洞
危急 SQL注入
2009-06-01 00:00:00 2009-06-02 00:00:00
远程  
        J2EE/RI Pointbase是一个纯JAVA数据库,可以方便的开发JAVA产品 。
        J2EE/RI (Reference Implementation) Pointbase数据库存在安全问题,远程攻击者可以利用这个漏洞通过jdbc插入任意代码或对数据库进行拒绝服务攻击 。
        通过使用特殊构建的SQL命令可导致在运行pointbase数据库的主机上执行任意代码。问题是由于jdk 1.4.2_02中的sun.*和org.apache.*库中漏洞及不充分的安全设置导致。利用这些漏洞也可能使攻击者对数据库进行拒绝服务攻击 。
        目前没有详细的漏洞细节提供 。
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://sunsolve.sun.com/security

- 漏洞信息

3072
J2EE SDK PointBase Database SQL Flaw

- 漏洞描述

Sun J2EE Reference Implementation on Windows contains a flaw that may allow a malicious user to execute arbitrary files on the host. The issue is triggered when specially crafted SQL statements are issued. It is possible that the flaw may allow DoS or information disclosure, resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2003-12-16 2003-11-29
Unknow Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround(s): Configure a Security Manager object for Pointbase.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站