CVE-2003-1511
CVSS4.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:37:07
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in Bajie Java HTTP Server 0.95 through 0.95zxv4 allows remote attackers to inject arbitrary web script or HTML via (1) the query string to test.txt, (2) the guestName parameter to the custMsg servlet, or (3) the cookiename parameter to the CookieExample servlet.


[CNNVD]Bajie HTTP Server 实例脚本和程序跨站脚本漏洞(CNNVD-200312-124)

        Bajie Java HTTP Server 0.95 到0.95zxv4版本存在跨站脚本(XSS)漏洞。远程攻击者借助(1)test.txt的字符串查询,(2)custMsg程序的guestName参数,或者(3)CookieExample程序的cookiename参数注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:bajie:java_http_server:0.95:zxe1
cpe:/a:bajie:java_http_server:0.95:d
cpe:/a:bajie:java_http_server:0.95
cpe:/a:bajie:java_http_server:0.95:zxc
cpe:/a:bajie:java_http_server:0.95:zxv4
cpe:/a:bajie:java_http_server:0.95:zxe

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1511
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1511
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-124
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/8841
(PATCH)  BID  8841
http://www.securityfocus.com/archive/1/341452
(UNKNOWN)  BUGTRAQ  20031016 CSS Vulnerability in Bajie HTTP JServer
http://securityreason.com/securityalert/3306
(UNKNOWN)  SREASON  3306
http://secunia.com/advisories/10023
(VENDOR_ADVISORY)  SECUNIA  10023
http://www.geocities.com/gzhangx/websrv/docs/security.html
(UNKNOWN)  CONFIRM  http://www.geocities.com/gzhangx/websrv/docs/security.html

- 漏洞信息

Bajie HTTP Server 实例脚本和程序跨站脚本漏洞
中危 跨站脚本
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        Bajie Java HTTP Server 0.95 到0.95zxv4版本存在跨站脚本(XSS)漏洞。远程攻击者借助(1)test.txt的字符串查询,(2)custMsg程序的guestName参数,或者(3)CookieExample程序的cookiename参数注入任意web脚本或者HTML。

- 公告与补丁

        The author has fixed this issue in version 0.95zxv4 versions available on October 16th.
        Bajie Java HTTP Server 0.95 d
        
        Bajie Java HTTP Server 0.95 zxv4
        
        Bajie Java HTTP Server 0.95 zxe
        
        Bajie Java HTTP Server 0.95 zxe1
        
        Bajie Java HTTP Server 0.95
        
        Bajie Java HTTP Server 0.95 zxc
        

- 漏洞信息 (23257)

Bajie HTTP Server 0.95 Example Scripts And Servlets Cross-Site Scripting Vulnerability (EDBID:23257)
multiple remote
2003-10-16 Verified
0 Oliver Karow
N/A [点击下载]
source: http://www.securityfocus.com/bid/8841/info

Demonstration scripts and servlets that are distributed as part of Bajie HTTP Server have been reported prone to multiple cross-site scripting vulnerabilities.

It has been reported that a remote attacker may construct a malicious link containing script and HTML code to any one of the vulnerable demonstration scripts or servlets on the affected server. If this link is followed the code contained therein will be rendered in the browser of the user who followed the link.

http://www.example.com/cgi/bin/test.txt?<script>alert(document.cookie)</script>
POST /servlet/custMsg?guestName=<script>alert("bang")</script> HTTP/1.0
POST /servlet/CookieExample?cookiename=<script>alert("bang")</script>&cookievalue=&cookiepath=
HTTP/1.0 		

- 漏洞信息

2689
Bajie HTTP Web Server Multiple XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Bajie HTTP Server contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate "guestName" and "cookiename" variables upon submission to the /servlet/custMsg and /servlet/CookieExample scripts. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-10-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 95zxv4rel or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站