CVE-2003-1500
CVSS6.8
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:37:06
NMCO    

[原文]PHP remote file inclusion vulnerability in _functions.php in cpCommerce 0.5f allows remote attackers to execute arbitrary code via the prefix parameter.


[CNNVD]CPCommerce远程文件包含漏洞(CNNVD-200312-440)

        
        e-commerce是一款开放源代码的电子商务解决方案。
        e-commerce包含的_functions.php脚本可包含远程文件,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。
        _functions.php包含如下有问题代码:
         require_once("{$prefix}_config.php");
         require_once("{$prefix}_gateways.php");
        由于对$prefix变量缺少充分过滤,攻击者可以指定远程服务器上的文件作为包含文件,可导致以WEB权限执行攻击者提供的恶意PHP命令。
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1500
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1500
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-440
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/13457
(UNKNOWN)  XF  cpCommerce-functionsphp-file-include(13457)
http://www.securityfocus.com/bid/8851
(UNKNOWN)  BID  8851
http://www.securityfocus.com/archive/1/341757
(UNKNOWN)  BUGTRAQ  20031019 ZH2003-31SA (security advisory): file inclusion vulnerability in cpCommerce
http://www.securiteam.com/unixfocus/6H00E2K8KG.html
(UNKNOWN)  MISC  http://www.securiteam.com/unixfocus/6H00E2K8KG.html
http://cpcommerce.org/forums/index.php?board=2;action=display;threadid=864
(UNKNOWN)  CONFIRM  http://cpcommerce.org/forums/index.php?board=2;action=display;threadid=864
http://securityreason.com/securityalert/3301
(UNKNOWN)  SREASON  3301

- 漏洞信息

CPCommerce远程文件包含漏洞
中危 输入验证
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        
        e-commerce是一款开放源代码的电子商务解决方案。
        e-commerce包含的_functions.php脚本可包含远程文件,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。
        _functions.php包含如下有问题代码:
         require_once("{$prefix}_config.php");
         require_once("{$prefix}_gateways.php");
        由于对$prefix变量缺少充分过滤,攻击者可以指定远程服务器上的文件作为包含文件,可导致以WEB权限执行攻击者提供的恶意PHP命令。
        

- 公告与补丁

        厂商补丁:
        cpCommerce
        ----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://cpcommerce.org/forums/index.php?board=2;action=display;threadid=864

- 漏洞信息

2702
cpCommerce in _functions.php prefix Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Patch / RCS
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2003-10-19 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站