发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:37:05

[原文]Cross-site scripting (XSS) vulnerability in search.php for WRENSOFT Zoom Search Engine 2.0 Build 1018 and earlier allows remote attackers to inject arbitrary web script or HTML via the zoom_query parameter.

[CNNVD]WrenSoft Zoom Search Engine跨站脚本漏洞(CNNVD-200312-368)

        WRENSOFT Zoom Search Engine 2.0 Build 1018版本及之前版本的search.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助zoom_query参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  8823
(PATCH)  BUGTRAQ  20031014 Cross-Site Scripting Vulnerability in Wrensoft Zoom Search Engine
(UNKNOWN)  XF  zoom-search-xss(13431)

- 漏洞信息

WrenSoft Zoom Search Engine跨站脚本漏洞
中危 跨站脚本
2003-12-31 00:00:00 2003-12-31 00:00:00
        WRENSOFT Zoom Search Engine 2.0 Build 1018版本及之前版本的search.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助zoom_query参数注入任意web脚本或HTML。

- 公告与补丁

        The vendor has released an upgrade to address this issue:
        WRENSOFT Zoom Search Engine 2.0 Build: 1018

- 漏洞信息 (23244)

WrenSoft Zoom Search Engine 2.0 Build: 1018 Cross-Site Scripting Vulnerability (EDBID:23244)
php webapps
2003-10-14 Verified
0 Ezhilan
N/A [点击下载]

WrenSoft Zoom Search Engine is prone to a cross-site scripting issue in the software's search module. A remote attacker may be able to execute HTML or script code in a user's browser.

The problem occurs because the software fails to properly sanitize user-supplied input. An attacker may be able to a construct a malicious link containing HTML or script code that may be rendered in a user's browser upon visiting that link. This attack would occur in the security context of the vulnerable site.<script>alert("hello")</script><script>alert("hello")</script> 		

- 漏洞信息

Zoom Search Engine search.php zoom_query Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Zoom Search Engine contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input variables upon submission to the search.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-10-15 2003-10-14
Unknow Unknow

- 解决方案

Upgrade to version 2.0 build 1019 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete