CVE-2003-1461
CVSS7.2
发布时间 :2003-12-31 00:00:00
修订时间 :2009-03-04 00:20:48
NMCOE    

[原文]Buffer overflow in rwrite for HP-UX 11.0 could allow local users to execute arbitrary code via a long argument. NOTE: the vendor was unable to reproduce the problem on a system that had been patched for an lp vulnerability (CVE-2002-1473).


[CNNVD]HP-UX rwrite本地缓冲区溢出漏洞(CNNVD-200312-235)

        
        HP-UX是惠普公司开发和维护的商业性质UNIX操作系统。
        HP-UX rwrite对参数缺少正确的边界缓冲区检查,本地程攻击者可以利用这个漏洞进行缓冲区溢出,可能以ROOT权限在系统上执行任意指令。
        当攻击者提供超长的参数给rwrite程序后,由于缺少边界检查,可导致程序崩溃,精心构建提交字符传,可能以root用户权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:4897HP-UX LP subsystem, Local Denial of Service (DoS)
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1461
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1461
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-235
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7489
(PATCH)  BID  7489
http://xforce.iss.net/xforce/xfdb/11919
(UNKNOWN)  XF  hp-rwrite-bo(11919)
http://www.securityfocus.com/archive/1/320371
(UNKNOWN)  BUGTRAQ  20030503 rwrite buffer overflow in hp-ux
http://www.securityfocus.com/archive/1/320323
(UNKNOWN)  BUGTRAQ  20030502 HP-UX 11.0 /usr/lbin/rwrite
http://securityreason.com/securityalert/3283
(UNKNOWN)  SREASON  3283

- 漏洞信息

HP-UX rwrite本地缓冲区溢出漏洞
高危 缓冲区溢出
2003-12-31 00:00:00 2009-03-04 00:00:00
本地  
        
        HP-UX是惠普公司开发和维护的商业性质UNIX操作系统。
        HP-UX rwrite对参数缺少正确的边界缓冲区检查,本地程攻击者可以利用这个漏洞进行缓冲区溢出,可能以ROOT权限在系统上执行任意指令。
        当攻击者提供超长的参数给rwrite程序后,由于缺少边界检查,可导致程序崩溃,精心构建提交字符传,可能以root用户权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        HP
        --
        HP已经宣布此漏洞的补丁包含在HPSBUX0208-213中,但是有建议说此补丁没有正确的进行修补:
        HP HP-UX 11.0:
        HP Patch PHCO_27132
        
        http://itrc.hp.com

- 漏洞信息 (22561)

HP-UX 11 RWrite Buffer Overflow Vulnerability (EDBID:22561)
hp-ux dos
2003-05-02 Verified
0 bt@delfi.lt
N/A [点击下载]
source: http://www.securityfocus.com/bid/7489/info

HP-UX rwrite utility has been reported prone to a buffer overflow vulnerability. Although unconfirmed code execution with elevated privileges may be possible.

The condition presents itself when excessive data is supplied as part of an argument passed to the vulnerable utility. Due to the lack of bounds checking, the vulnerable utility will crash.

The precise technical details of this vulnerability are currently unknown. This BID will be updated, as further information is available.

$ /usr/lbin/rwrite something `perl -e 'print "A" x 14628'` something 		

- 漏洞信息

60339
HP-UX rwrite Argument Handling Local Overflow
Local Access Required Input Manipulation
Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

- 时间线

2003-05-02 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, HP has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站