CVE-2003-1455
CVSS7.2
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:58
NMCO    

[原文]Multiple buffer overflows in the launch_bcrelay function in pptpctrl.c in PoPToP 1.1.4-b1 through PoPToP 1.1.4-b3 allow local users to execute arbitrary code.


[CNNVD]Poptop PPTP BCRELAY sprintf()本地缓冲区溢出漏洞(CNNVD-200312-154)

        
        PoPToP PPTP一般用于建立VPN连接,可使用在多种Linux系统下。
        PoPToP PPTP在调用sprinf()和fscanf()函数的时候缺少正确边界缓冲区检查,本地攻击者可以利用这个漏洞提供超长数据给程序,触发缓冲区溢出,可能以root用户权限在系统上执行任意指令。
        目前没有详细漏洞细节提供,此漏洞将会在以后更新。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:poptop:pptp_server:1.1.4b2
cpe:/a:poptop:pptp_server:1.1.4b1
cpe:/a:poptop:pptp_server:1.1.4b3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1455
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1455
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-154
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7590
(PATCH)  BID  7590
http://www.securityfocus.com/bid/7582
(PATCH)  BID  7582
http://sourceforge.net/project/shownotes.php?release_id=138437
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=138437
http://xforce.iss.net/xforce/xfdb/12101
(UNKNOWN)  XF  poptop-launchbcrelay-pptpctrlc-bo(12101)

- 漏洞信息

Poptop PPTP BCRELAY sprintf()本地缓冲区溢出漏洞
高危 边界条件错误
2003-12-31 00:00:00 2003-12-31 00:00:00
本地  
        
        PoPToP PPTP一般用于建立VPN连接,可使用在多种Linux系统下。
        PoPToP PPTP在调用sprinf()和fscanf()函数的时候缺少正确边界缓冲区检查,本地攻击者可以利用这个漏洞提供超长数据给程序,触发缓冲区溢出,可能以root用户权限在系统上执行任意指令。
        目前没有详细漏洞细节提供,此漏洞将会在以后更新。
        

- 公告与补丁

        厂商补丁:
        PoPToP
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        PoPToP Upgrade pptpd-1.1.4-b4.tar.gz
        
        http://sourceforge.net/project/showfiles.php?group_id=44827

- 漏洞信息

59804
PoPToP pptpctrl.c pptpctrl.c Function Multiple Local Overflows
Local Access Required Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-05-13 Unknow
Unknow 2003-05-13

- 解决方案

Upgrade to version 1.1.4-b4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站