CVE-2003-1453
CVSS4.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:58
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in the MytextSanitizer function in XOOPS 1.3.5 through 1.3.9 and XOOPS 2.0 through 2.0.1 allows remote attackers to inject arbitrary web script or HTML via a javascript: URL in an IMG tag.


[CNNVD]Xoops MyTextSanitizer HTML注入漏洞(CNNVD-200312-438)

        XOOPS 1.3.5至1.3.9版本和XOOPS 2.0 至2.0.1版本的MytextSanitizer函数存在跨站脚本(XSS)漏洞。远程攻击者可以借助javascript:IMG标签中的URL注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:xoops:xoops:2.0
cpe:/a:xoops:xoops:2.0.1
cpe:/a:xoops:xoops:1.3.6
cpe:/a:xoops:xoops:1.3.8
cpe:/a:xoops:xoops:1.3.7
cpe:/a:xoops:xoops:1.3.9
cpe:/a:xoops:xoops:1.3.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1453
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1453
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-438
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7434
(PATCH)  BID  7434
http://xforce.iss.net/xforce/xfdb/11872
(UNKNOWN)  XF  xoops-mytextsanitizer-xss(11872)
http://www.securityfocus.com/archive/1/319715
(UNKNOWN)  BUGTRAQ  20030425 XOOPS MyTextSanitizer CSS 1.3x & 2.x
http://securityreason.com/securityalert/3269
(UNKNOWN)  SREASON  3269

- 漏洞信息

Xoops MyTextSanitizer HTML注入漏洞
中危 跨站脚本
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        XOOPS 1.3.5至1.3.9版本和XOOPS 2.0 至2.0.1版本的MytextSanitizer函数存在跨站脚本(XSS)漏洞。远程攻击者可以借助javascript:IMG标签中的URL注入任意web脚本或HTML。

- 公告与补丁

        Xoops 1.3.10 and 2.0.2 have been released which address this issue. Users are advised to upgrade as soon as possible.
        Xoops Xoops 1.3.5
        
        Xoops Xoops 1.3.6
        
        Xoops Xoops 1.3.7
        
        Xoops Xoops 1.3.8
        
        Xoops Xoops 1.3.9
        
        Xoops Xoops 2.0
        
        Xoops Xoops 2.0.1
        

- 漏洞信息 (22539)

Xoops 1.3.x/2.0 MyTextSanitizer HTML Injection Vulnerability (EDBID:22539)
php webapps
2003-04-25 Verified
0 magistrat
N/A [点击下载]
source: http://www.securityfocus.com/bid/7434/info

A HTML injection vulnerability has been discovered in Xoops. The problem occurs due to insufficient filtering of HTML and script code by the MyTextSanitizer script.

Successful exploitation of this vulnerability may allow a malicious Xoops user to execute arbitrary HTML or script code within the browser of a legitimate user. 

java script:alert%28document.cookie%29

The script code must be embedded within HTML <img> tags. 		

- 漏洞信息

59320
XOOPS MyTextSanitizer Function XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

Xoops contains a flaw that allows a remote cross site scripting (XSS) attack. This flaw exists because the application does not validate the input provided to the MyTextSantizer() function upon submission. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2003-04-25 Unknow
Unknow 2003-04-25

- 解决方案

Upgrade to version 1.3.10 or 2.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站