CVE-2003-1441
CVSS4.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:56
NMCO    

[原文]Posadis 0.50.4 through 0.50.8 allows remote attackers to cause a denial of service (crash) via a DNS message without a question section, which triggers null dereference.


[CNNVD]Posadis DNS请求问题区远程拒绝服务漏洞(CNNVD-200312-421)

        
        Posadis是一款开放源代码的DNS服务程序,设计目标是方便使用和配置,运行在Linux、Unix、Microsoft操作系统下。
        Posadis在处理部分DNS请求时存在问题,远程攻击者可以利用这个漏洞对DNS服务程序进行拒绝服务攻击。
        Posadis在检查DNS消息中是否包含问题区存在边界错误,通过发送恶意的DNS消息请求可以使DNS服务器崩溃。目前还不知道此漏洞是否可以用来在系统执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-20 [输入验证不恰当]

- CPE (受影响的平台与产品)

cpe:/a:posadis:posadis:0.50.6
cpe:/a:posadis:posadis:0.50.4
cpe:/a:posadis:posadis:0.50.7
cpe:/a:posadis:posadis:0.50.5
cpe:/a:posadis:posadis:0.50.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1441
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1441
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-421
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6799
(PATCH)  BID  6799
http://xforce.iss.net/xforce/xfdb/11285
(UNKNOWN)  XF  posadis-dns-packet-dos(11285)
http://www.osvdb.org/3522
(UNKNOWN)  OSVDB  3522
http://secunia.com/advisories/8018
(UNKNOWN)  SECUNIA  8018

- 漏洞信息

Posadis DNS请求问题区远程拒绝服务漏洞
中危 其他
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        
        Posadis是一款开放源代码的DNS服务程序,设计目标是方便使用和配置,运行在Linux、Unix、Microsoft操作系统下。
        Posadis在处理部分DNS请求时存在问题,远程攻击者可以利用这个漏洞对DNS服务程序进行拒绝服务攻击。
        Posadis在检查DNS消息中是否包含问题区存在边界错误,通过发送恶意的DNS消息请求可以使DNS服务器崩溃。目前还不知道此漏洞是否可以用来在系统执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Posadis
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Posadis Upgrade posadis-0.50.9.tar.gz
        
        http://prdownloads.sf.net/posadis/posadis-0.50.9.tar.gz

        Posadis Upgrade posadis-0.50.9.exe
        
        http://prdownloads.sf.net/posadis/posadis-0.50.9.exe

- 漏洞信息

3522
Posadis DNS Request Question Section DoS
Denial of Service
Loss of Availability

- 漏洞描述

Posadis DNS server contains a flaw that allows a remote attacker to crash the service. The issue is due to the service not properly handling a malformed packet which caused it to read from NULL, therefore crashing the service.

- 时间线

2003-02-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.50.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站