CVE-2003-1426
CVSS3.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:54
NMCO    

[原文]Openwebmail in cPanel 5.0, when run using suid Perl, adds the directory in the SCRIPT_FILENAME environment variable to Perl's @INC include array, which allows local users to execute arbitrary code by modifying SCRIPT_FILENAME to reference a directory containing a malicious openwebmail-shared.pl executable.


[CNNVD]cPanel Openwebmail本地权限提升漏洞(CNNVD-200312-123)

        
        Cpanel是一款WEB主机控制程序,允许客户通过WEB接口管理WEB帐户。
        Cpanel包含的openwebmail工具对环境变量处理不正确,本地攻击者可以利用这个漏洞进行权限提升攻击,以高权限在系统上执行任意命令。
        openwebmail是用于WEB邮件读取,以suid root属性安装,Openwebmail会通过SCRIPT_FILENAME还击功能变量设置要包含的脚本文件,如:
        /usr/local/cpanel/base/openwebmail/oom 14行:
        if ( $ENV{'SCRIPT_FILENAME'} =~ m!^(.*?)/[\w\d\-]+\.pl! || $0 =~ m!^(.*?)/[\w\d\-]+\.pl! ) {
        $SCRIPT_DIR=$1; }
        if (!$SCRIPT_DIR) { print "Content-type: text/html\n\n\$SCRIPT_DIR not set in CGI script!\n";
        exit 0; }
        push (@INC, $SCRIPT_DIR, ".");
        .
        .
        .
        require "openwebmail-shared.pl";
        攻击者可以建立包含恶意代码的openwebmail-shared.pl脚本,并设置SCRIPT_FILENAME指定openwebmail-shared.pl的全路径,然后执行oom脚本(如suidperl -T /usr/local/cpanel/base/openwebmail/oom),就可以以高权限在系统上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 3.3 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-16 [配置]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1426
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1426
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-123
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/11357
(UNKNOWN)  XF  cpanel-scriptfilename-gain-privileges(11357)
http://www.securityfocus.com/bid/6885
(UNKNOWN)  BID  6885
http://archives.neohapsis.com/archives/vulnwatch/2003-q1/0087.html
(UNKNOWN)  VULNWATCH  20030218 Cpanel 5 and below remote command execution and local root vulnerabilities

- 漏洞信息

cPanel Openwebmail本地权限提升漏洞
低危 输入验证
2003-12-31 00:00:00 2003-12-31 00:00:00
本地  
        
        Cpanel是一款WEB主机控制程序,允许客户通过WEB接口管理WEB帐户。
        Cpanel包含的openwebmail工具对环境变量处理不正确,本地攻击者可以利用这个漏洞进行权限提升攻击,以高权限在系统上执行任意命令。
        openwebmail是用于WEB邮件读取,以suid root属性安装,Openwebmail会通过SCRIPT_FILENAME还击功能变量设置要包含的脚本文件,如:
        /usr/local/cpanel/base/openwebmail/oom 14行:
        if ( $ENV{'SCRIPT_FILENAME'} =~ m!^(.*?)/[\w\d\-]+\.pl! || $0 =~ m!^(.*?)/[\w\d\-]+\.pl! ) {
        $SCRIPT_DIR=$1; }
        if (!$SCRIPT_DIR) { print "Content-type: text/html\n\n\$SCRIPT_DIR not set in CGI script!\n";
        exit 0; }
        push (@INC, $SCRIPT_DIR, ".");
        .
        .
        .
        require "openwebmail-shared.pl";
        攻击者可以建立包含恶意代码的openwebmail-shared.pl脚本,并设置SCRIPT_FILENAME指定openwebmail-shared.pl的全路径,然后执行oom脚本(如suidperl -T /usr/local/cpanel/base/openwebmail/oom),就可以以高权限在系统上执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * chmod 755 /usr/local/cpanel/base/openwebmail/oom
        厂商补丁:
        cPanel
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.cpanel.net

- 漏洞信息

60429
Openwebmail Crafted SCRIPT_FILENAME Environment Variable Local Privilege Escalation
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2003-02-18 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站