CVE-2003-1416
CVSS4.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:52
NMCO    

[原文]BisonFTP Server 4 release 2 allows remote attackers to cause a denial of service (CPU consumption) via a long (1) ls or (2) cwd command.


[CNNVD]BisonFTP超长命令远程拒绝服务漏洞(CNNVD-200312-213)

        
        BisonFTP是一款可使用在Microsoft Windows 9x/NT操作系统上的FTP服务程序。
        BisonFTP处理超长的'cwd'或'ls'命令不正确,远程攻击者可以利用这个漏洞对服务程序进行拒绝服务攻击。
        攻击者发送包含4300字节的'cwd'或'ls'命令给FTP服务程序,可导致BisonFTP所在系统CPU使用率达100%,导致停止对正常请求的服务。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-20 [输入验证不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1416
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1416
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-213
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/11346
(UNKNOWN)  XF  bisonftp-ls-cwd-dos(11346)
http://www.securityfocus.com/bid/6869
(UNKNOWN)  BID  6869
http://www.securityfocus.com/archive/1/312032
(UNKNOWN)  BUGTRAQ  20030217 [immune advisory] Mulitple vulnerabilities found in BisonFTP

- 漏洞信息

BisonFTP超长命令远程拒绝服务漏洞
中危 其他
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        
        BisonFTP是一款可使用在Microsoft Windows 9x/NT操作系统上的FTP服务程序。
        BisonFTP处理超长的'cwd'或'ls'命令不正确,远程攻击者可以利用这个漏洞对服务程序进行拒绝服务攻击。
        攻击者发送包含4300字节的'cwd'或'ls'命令给FTP服务程序,可导致BisonFTP所在系统CPU使用率达100%,导致停止对正常请求的服务。
        

- 公告与补丁

        厂商补丁:
        BisonFTP
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.bisonftp.com

- 漏洞信息

59612
BisonFTP Multiple Command Handling Remote Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability Discontinued Product
Exploit Unknown

- 漏洞描述

BisonFTP contains a flaw that may allow a remote denial of service. The issue is triggered when commands 'cwd' and 'ls' handle long arguments (more than 4300 bytes), and will result in loss of availability for the platform.

- 时间线

2003-02-17 Unknow
Unknow Unknow

- 解决方案

The vendor has discontinued this product and therefore has no patch or upgrade that mitigates this problem. It is recommended that an alternate software package be used in its place.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站