CVE-2003-1373
CVSS6.8
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:46
NMCO    

[原文]Directory traversal vulnerability in auth.php for PhpBB 1.4.0 through 1.4.4 allows remote attackers to read and include arbitrary files via .. (dot dot) sequences followed by NULL (%00) characters in CGI parameters, as demonstrated using the lang parameter in prefs.php.


[CNNVD]PHPBB Auth.PHP文件泄漏漏洞(CNNVD-200312-455)

        PhpBB 1.4.0至1.4.4版本的auth.php存在目录遍历漏洞。远程攻击者可以借助后跟CGI参数的空(%00)字符的..(dot dot)序列读取并包含任意文件,正如prefs.php使用lang参数。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:1.4.4
cpe:/a:phpbb_group:phpbb:1.4.0
cpe:/a:phpbb_group:phpbb:1.4.1
cpe:/a:phpbb_group:phpbb:1.4.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1373
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1373
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-455
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/11407
(PATCH)  XF  phpbb-auth-read-files(11407)
http://www.securityfocus.com/bid/6889
(UNKNOWN)  BID  6889
http://archives.neohapsis.com/archives/bugtraq/2003-02/0245.html
(UNKNOWN)  BUGTRAQ  20030220 phpBB Security Bugs

- 漏洞信息

PHPBB Auth.PHP文件泄漏漏洞
中危 输入验证
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        PhpBB 1.4.0至1.4.4版本的auth.php存在目录遍历漏洞。远程攻击者可以借助后跟CGI参数的空(%00)字符的..(dot dot)序列读取并包含任意文件,正如prefs.php使用lang参数。

- 公告与补丁

        It has been reported that the vendor will not be releasing fixes for phpBB 1.4.x. Users are advised to upgrade to phpBB2, which is actively supported by the vendor.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

60187
phpBB auth.php Traversal Arbitrary PHP Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-02-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站