CVE-2003-1365
CVSS5.0
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:44
NMCO    

[原文]The escape_dangerous_chars function in CGI::Lite 2.0 and earlier does not correctly remove special characters including (1) "\" (backslash), (2) "?", (3) "~" (tilde), (4) "^" (carat), (5) newline, or (6) carriage return, which could allow remote attackers to read or write arbitrary files, or execute arbitrary commands, in shell scripts that rely on CGI::Lite to filter such dangerous inputs.


[CNNVD]CGI Lite Perl模块元字符输入验证漏洞(CNNVD-200312-337)

        
        CGI::Lite Perl模块可以用来处理'multipart form'形式的资料(即上传)。
        CGI::Lite Perl模块中的escape_dangerous_chars()函数不正确过滤用户提交的恶意字符,远程攻击者可以利用这个漏洞以CGI程序权限在系统上执行任意命令。
        CGI::Lite::escape_dangerous_chars()函数没有正确过滤所有危险的字符,如'\ ? ~ ^ \n \r',结果可导致外部提供的输入由于没有进行充分过滤,直接用于其他Perl函数,可以导致以CGI权限在系统上执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-20 [输入验证不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1365
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1365
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-337
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/11308
(UNKNOWN)  XF  cgilite-shell-command-execution(11308)
http://www.securityfocus.com/bid/6833
(UNKNOWN)  BID  6833
http://www.securityfocus.com/archive/1/311414
(UNKNOWN)  BUGTRAQ  20030211 Security bug in CGI::Lite::escape_dangerous_chars() function
http://use.perl.org/~cbrooks/journal/10542
(UNKNOWN)  MISC  http://use.perl.org/~cbrooks/journal/10542
http://search.cpan.org/~smylers/CGI-Lite-2.02/Lite.pm
(UNKNOWN)  CONFIRM  http://search.cpan.org/~smylers/CGI-Lite-2.02/Lite.pm
http://archives.neohapsis.com/archives/vulnwatch/2003-q1/0065.html
(UNKNOWN)  VULNWATCH  20030211 Security bug in CGI::Lite::escape_dangerous_chars() function
http://securityreason.com/securityalert/3237
(UNKNOWN)  SREASON  3237

- 漏洞信息

CGI Lite Perl模块元字符输入验证漏洞
中危 输入验证
2003-12-31 00:00:00 2003-12-31 00:00:00
远程  
        
        CGI::Lite Perl模块可以用来处理'multipart form'形式的资料(即上传)。
        CGI::Lite Perl模块中的escape_dangerous_chars()函数不正确过滤用户提交的恶意字符,远程攻击者可以利用这个漏洞以CGI程序权限在系统上执行任意命令。
        CGI::Lite::escape_dangerous_chars()函数没有正确过滤所有危险的字符,如'\ ? ~ ^ \n \r',结果可导致外部提供的输入由于没有进行充分过滤,直接用于其他Perl函数,可以导致以CGI权限在系统上执行任意命令。
        

- 公告与补丁

        厂商补丁:
        Benjamin Low
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://search.cpan.org/author/BENL/CGI-Lite-2.0/Lite.pm

- 漏洞信息

60398
CGI::Lite escape_dangerous_chars Function Multiple Character Filtering Weakness
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-02-11 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站