CVE-2003-1337
CVSS7.5
发布时间 :2003-12-31 00:00:00
修订时间 :2010-06-23 00:00:00
NMCO    

[原文]Heap-based buffer overflow in Aprelium Abyss Web Server 1.1.2 and earlier allows remote attackers to execute arbitrary code via a long HTTP GET request.


[CNNVD]Abyss Web Server远程超长GET请求堆破坏漏洞(CNNVD-200312-172)

        
        Abyss Web Server是一宽免费的个人性质的WEB服务程序。
        Abyss Web服务程序由于没有充分检查通过用户提交的HTTP GET请求,远程攻击者可以利用这个漏洞对服务进行缓冲区溢出攻击,可能以WEB进程权限在系统上执行任意指令。
        Abyss Web服务对GET请求在堆上分配0x800大小的缓冲区,由于在调用strcpy()函数时没有对输入参数进行边界缓冲区检查,通过提交超长GET请求并最后追加":\"字符,可触发溢出,精心构建提交数据可能以WEB进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1337
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1337
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-172
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/12466
(PATCH)  XF  abyss-http-get-bo(12466)
http://www.securityfocus.com/bid/8062
(PATCH)  BID  8062
http://archives.neohapsis.com/archives/bugtraq/2003-06/0235.html
(UNKNOWN)  BUGTRAQ  20030629 Aprelium Abyss webserver X1 arbitrary code execution and header injection

- 漏洞信息

Abyss Web Server远程超长GET请求堆破坏漏洞
高危 缓冲区溢出
2003-12-31 00:00:00 2007-09-24 00:00:00
远程  
        
        Abyss Web Server是一宽免费的个人性质的WEB服务程序。
        Abyss Web服务程序由于没有充分检查通过用户提交的HTTP GET请求,远程攻击者可以利用这个漏洞对服务进行缓冲区溢出攻击,可能以WEB进程权限在系统上执行任意指令。
        Abyss Web服务对GET请求在堆上分配0x800大小的缓冲区,由于在调用strcpy()函数时没有对输入参数进行边界缓冲区检查,通过提交超长GET请求并最后追加":\"字符,可触发溢出,精心构建提交数据可能以WEB进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Aprelium Technologies
        ---------------------
        目前厂商已经在1.1.6及以后的版本中修复了这个安全问题,请到厂商的主页下载:
        
        http://www.aprelium.com

- 漏洞信息

50471
Abyss Web Server GET Request Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Commercial Vendor Verified

- 漏洞描述

- 时间线

2003-06-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站