发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:35

[原文]CRLF injection vulnerability in fvwm-menu-directory for fvwm 2.5.x before 2.5.10 and 2.4.x before 2.4.18 allows local users to execute arbitrary commands via carriage returns in a filename.

[CNNVD]FVWM fvwm-menu-directory本地命令执行漏洞(CNNVD-200312-287)

        FVWM是一款X Window的窗口管理程序。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  9161

- 漏洞信息

FVWM fvwm-menu-directory本地命令执行漏洞
中危 输入验证
2003-12-31 00:00:00 2006-11-20 00:00:00
        FVWM是一款X Window的窗口管理程序。

- 公告与补丁


- 漏洞信息 (23414)

FVWM 2.4/2.5 fvwm-menu-directory Command Execution Vulnerability (EDBID:23414)
linux local
2003-12-05 Verified
0 auto22238
N/A [点击下载]

It has been reported that FVWM may be prone to a command execution vulnerability that may allow an attacker to execute malicious commands on a vulnerable system. It has been reported that the fvwm-menu-directory component does not properly sanitize user input and allows a user with write permissions to a directory to execute arbitrary commands.

FVWM versions 2.14.17 and 2.5.8 have been reported to be vulnerable to this issue, however other versions may be affected as well. 

$ touch '
> Exec xmessage "0wn3d"
> '
$ write fvwmguy <<< "k3wl mp3 in `pwd` OMG LOLOLOL!!!1111" 		

- 漏洞信息

FVWM Filename eoln Command Execution
Local Access Required Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

The FVWM window manager contains a flaw that may allow a malicious user to prepare a script containing malicious commands for execution by another user. The issue is triggered when FVWM opens the directory in which the script is placed. It is possible that the flaw may allow execution of resulting in a loss of confidentiality and integrity.

- 时间线

2003-12-05 2003-12-05
Unknow Unknow

- 解决方案

Upgrade to version 2.5.9, 2.4.18 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者