CVE-2003-1271
CVSS4.3
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:29
NMCOE    

[原文]Cross-site scripting vulnerability (XSS) in AN HTTP 1.41e allows remote attackers to execute arbitrary web script or HTML as other users via a URL containing the script.


[CNNVD]AN HTTPD跨站脚本漏洞(CNNVD-200312-370)

        AN HTTP 1.41e版本存在跨站脚本漏洞(XSS)。远程攻击者可以像其他用户借助含脚本的URL执行任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1271
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1271
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-370
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6529
(PATCH)  BID  6529
http://www.securityfocus.com/archive/1/305234
(VENDOR_ADVISORY)  BUGTRAQ  20030104 AN HTTPd v.1.41e: DoS, CSS, real patch attack
http://www.iss.net/security_center/static/10977.php
(UNKNOWN)  XF  an-http-script-xss(10977)

- 漏洞信息

AN HTTPD跨站脚本漏洞
中危 跨站脚本
2003-12-31 00:00:00 2006-01-20 00:00:00
远程  
        AN HTTP 1.41e版本存在跨站脚本漏洞(XSS)。远程攻击者可以像其他用户借助含脚本的URL执行任意web脚本或HTML。

- 公告与补丁

        The vendor has released AN-HTTPD 1.42f which addresses this issue. Users are advised to upgrade as soon as possible.
        AN AN-HTTPd 1.41 e
        

- 漏洞信息 (22130)

AN HTTPD 1.41 e Cross Site Scripting Vulnerability (EDBID:22130)
multiple remote
2003-01-06 Verified
0 D4rkGr3y
N/A [点击下载]
source: http://www.securityfocus.com/bid/6529/info

AN HTTPD does not adequately filter HTML code thus making it prone to cross-site scripting attacks. It is possible for a remote attacker to create a malicious link containing script code which will be executed in the browser of a legitimate user. All code will be executed within the context of the website running AN HTTPD.

This issue may be exploited to steal cookie-based authentication credentials from legitimate users of the website running the vulnerable software. 

http://www.target.com/[script]?<h1>HACKED</h1>aaaa..[up_to_1kb]..aaaa 		

- 漏洞信息

59639
AN HTTP Query String XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public

- 漏洞描述

- 时间线

2003-01-04 Unknow
2003-01-04 Unknow

- 解决方案

Upgrade to version 1.42f or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站