CVE-2003-1259
CVSS7.5
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:27
NMCO    

[原文]Buffer overflow in CuteFTP 4.2 and 5.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long FTP server banner.


[CNNVD]GlobalScape CuteFTP超长FTP旗标远程缓冲区溢出漏洞(CNNVD-200312-194)

        
        CuteFTP是一款基于Windows的文件传输协议客户端。
        CuteFTP不能正确处理超长FTP旗标(banner),远程攻击者可以利用这个漏洞在自己控制的服务器上构建恶意旗标数据,诱使用户访问时使CuteFTP发生缓冲区溢出。
        CuteFTP在处理超过2048字节的FTP旗标(banner)时会触发缓冲区溢出,攻击者精心构建恶意FTP旗标,当客户端访问恶意服务器时,可能以执行CuteFTP用户权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1259
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1259
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-194
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/325659
(PATCH)  BUGTRAQ  20030618 Re: CuteFTP 5.0 XP, Buffer Overflow
http://www.securityfocus.com/bid/6518
(UNKNOWN)  BID  6518
http://www.iss.net/security_center/static/10984.php
(UNKNOWN)  XF  cuteftp-ftp-banner-bo(10984)
http://archives.neohapsis.com/archives/bugtraq/2003-01/0026.html
(VENDOR_ADVISORY)  BUGTRAQ  20030104 CuteFTP: buffer overflow

- 漏洞信息

GlobalScape CuteFTP超长FTP旗标远程缓冲区溢出漏洞
高危 边界条件错误
2003-12-31 00:00:00 2006-01-19 00:00:00
远程  
        
        CuteFTP是一款基于Windows的文件传输协议客户端。
        CuteFTP不能正确处理超长FTP旗标(banner),远程攻击者可以利用这个漏洞在自己控制的服务器上构建恶意旗标数据,诱使用户访问时使CuteFTP发生缓冲区溢出。
        CuteFTP在处理超过2048字节的FTP旗标(banner)时会触发缓冲区溢出,攻击者精心构建恶意FTP旗标,当客户端访问恶意服务器时,可能以执行CuteFTP用户权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        globalSCAPE
        -----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.globalscape.com

- 漏洞信息

59840
CuteFTP Server Banner Handling Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

- 时间线

2003-01-04 Unknow
Unknow 2003-06-09

- 解决方案

Upgrade to version 5.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站