发布时间 :2003-12-31 00:00:00
修订时间 :2012-12-12 21:24:28

[原文]Cross-site scripting (XSS) vulnerability in the tep_href_link function in html_output.php for osCommerce before 2.2-MS3 allows remote attackers to inject arbitrary web script or HTML via the osCsid parameter.

[CNNVD]osCommerce osCsid参数跨站脚本漏洞(CNNVD-200312-331)

        osCommerce 2.2-MS3之前版本中html_output.php的tep_href_link函数存在跨站脚本(XSS)漏洞。远程攻击者可以借助osCsid参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  9238
(UNKNOWN)  BUGTRAQ  20031217 osCommerce Malformed Session ID XSS Vuln,1546
(UNKNOWN)  MLIST  [tep-commits] 20031217 [TEP-COMMIT] CVS: catalog/catalog/includes/functions html_output.php,1.58,1.59

- 漏洞信息

osCommerce osCsid参数跨站脚本漏洞
中危 跨站脚本
2003-12-31 00:00:00 2006-03-29 00:00:00
        osCommerce 2.2-MS3之前版本中html_output.php的tep_href_link函数存在跨站脚本(XSS)漏洞。远程攻击者可以借助osCsid参数注入任意web脚本或HTML。

- 公告与补丁

        It has been reported that osCommerce 2.2 Milestone 3 is not affected by this issue. Users are advised to contact the vendor for more information about obtaining fixes.

- 漏洞信息 (23445)

osCommerce 2.2 osCsid Parameter Cross-Site Scripting Vulnerability (EDBID:23445)
php webapps
2003-12-17 Verified
0 JeiAr
N/A [点击下载]

It has been reported that osCommerce may be prone to a cross-site scripting vulnerability that may allow an attacker to construct a malicious link containing HTML or script code that may be rendered in a user's browser.

Successful exploitation of this attack may allow an attacker to steal cookie-based authentication credentials. Other attacks are also possible.

Although unconfirmed, osCommerce versions 2.2 Milestone 1 and 2.2 Milestone 2 may be vulnerable to this issue."><iframe src=></iframe> 		

- 漏洞信息

osCommerce osCsid Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

osCommerce contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the osCsid variable upon submission. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-12-18 Unknow
2003-12-18 Unknow

- 解决方案

Upgrade to version osCommerce 2.2 Milestone 3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete