CVE-2003-1215
CVSS4.6
发布时间 :2003-12-29 00:00:00
修订时间 :2016-10-17 22:39:33
NMCOS    

[原文]SQL injection vulnerability in groupcp.php for phpBB 2.0.6 and earlier allows group moderators to perform unauthorized activities via the sql_in parameter.


[CNNVD]phpBB groupcp.php SQL注入漏洞(CNNVD-200312-065)

        
        phpBB是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。
        phpBB包含的groupcp.php脚本对用户提交的URI参数缺少充分过滤,远程攻击者可以利用这个漏洞进行SQL注入攻击,可获得敏感信息或者修改数据库。
        问题是groupcp.php脚本对$sql_in变量缺少充分过滤,提交恶意SQL命令作为参数给$sql_in变量,可以删除组中任何一个成员。或获得部分敏感信息。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:1.4.4
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0_rc1
cpe:/a:phpbb_group:phpbb:2.0_rc2
cpe:/a:phpbb_group:phpbb:2.0_rc3
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:1.2.1
cpe:/a:phpbb_group:phpbb:1.4.0
cpe:/a:phpbb_group:phpbb:1.4.1
cpe:/a:phpbb_group:phpbb:2.0_beta1
cpe:/a:phpbb_group:phpbb:1.4.2
cpe:/a:phpbb_group:phpbb:1.0.0
cpe:/a:phpbb_group:phpbb:2.0.6
cpe:/a:phpbb_group:phpbb:1.2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1215
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1215
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-065
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107273069130885&w=2
(UNKNOWN)  BUGTRAQ  20031229 SQL Injection in phpBB's groupcp.php
http://www.phpbb.com/phpBB/viewtopic.php?f=14&t=161943
(VENDOR_ADVISORY)  CONFIRM  http://www.phpbb.com/phpBB/viewtopic.php?f=14&t=161943
http://www.securityfocus.com/bid/9314
(VENDOR_ADVISORY)  BID  9314
http://xforce.iss.net/xforce/xfdb/14096
(VENDOR_ADVISORY)  XF  phpbb-groupcp-sql-injection(14096)

- 漏洞信息

phpBB groupcp.php SQL注入漏洞
中危 输入验证
2003-12-29 00:00:00 2005-10-20 00:00:00
远程  
        
        phpBB是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。
        phpBB包含的groupcp.php脚本对用户提交的URI参数缺少充分过滤,远程攻击者可以利用这个漏洞进行SQL注入攻击,可获得敏感信息或者修改数据库。
        问题是groupcp.php脚本对$sql_in变量缺少充分过滤,提交恶意SQL命令作为参数给$sql_in变量,可以删除组中任何一个成员。或获得部分敏感信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 打开groupcp.php文件,找到如下行:
        $sql_in .= ( ( $sql_in != '' ) ? ', ' : '' ) . $members[$i];
        并用如下行代替:
        $sql_in .= ( ( $sql_in != '' ) ? ', ' : '' ) . intval($members[$i]);
        厂商补丁:
        phpBB Group
        -----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.phpbb.com/

- 漏洞信息

3302
phpBB groupcp.php sql_in Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

phpBB contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the $sql_in variable is not verified properly in "groupcp.php" and will allow an attacker with moderator privilege to inject arbitrary SQL queries.

- 时间线

2003-12-29 2003-12-29
Unknow Unknow

- 解决方案

Upgrade to version 2.0.6 found on the vendor site or higher, as it has been reported to fix this vulnerability. It is important to note that the issue was fixed and the version number was not incremented. It is also possible to correct the flaw by implementing the following workaround(s): To fix this vulnerability, it's fairly simple. Open your groupcp.php file. Find $sql_in .= ( ( $sql_in != ' ) ? ', ' : ' ) . $members[$i]; and replace it with $sql_in .= ( ( $sql_in != ' ) ? ', ' : ' ) . intval($members[$i]);

- 相关参考

- 漏洞作者

- 漏洞信息

phpBB GroupCP.PHP SQL Injection Vulnerability
Input Validation Error 9314
Yes No
2003-12-29 12:00:00 2009-07-12 12:56:00
Discovery of this vulnerability has been credited to Jay Gates <zarath@knightsofchaos.com>.

- 受影响的程序版本

phpBB Group phpBB 2.0.7
phpBB Group phpBB 2.0.6
phpBB Group phpBB 2.0.5
phpBB Group phpBB 2.0.4
phpBB Group phpBB 2.0.3
phpBB Group phpBB 2.0.2
phpBB Group phpBB 2.0.1
phpBB Group phpBB 2.0 .0
phpBB Group phpBB 2.0 RC4
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC3
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC2
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 RC1
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0 Beta 1
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 1.4.4
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 1.4.2
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 1.4.1
phpBB Group phpBB 1.4 .0
phpBB Group phpBB 1.2.1
phpBB Group phpBB 1.2 .0
phpBB Group phpBB 1.0 .0
phpBB Group phpBB 2.0.6 c

- 不受影响的程序版本

phpBB Group phpBB 2.0.6 c

- 漏洞讨论

A vulnerability has been reported to exist in the software that may allow a remote user who has group moderator privileges to inject malicious SQL syntax into database queries. The problem reportedly exists in parameters of the groupcp.php script. This issue is caused by insufficient sanitization of user-supplied data. A remote attacker may exploit this issue to influence SQL query logic to have unauthorized SQL queries executed in the database.

- 漏洞利用

There is no exploit required.

- 解决方案

The vendor has released phpBB 2.0.6c to address this and other issues. Users are advised to upgrade to the fixed version.


phpBB Group phpBB 1.0 .0

phpBB Group phpBB 1.2 .0

phpBB Group phpBB 1.2.1

phpBB Group phpBB 1.4 .0

phpBB Group phpBB 1.4.1

phpBB Group phpBB 1.4.2

phpBB Group phpBB 1.4.4

phpBB Group phpBB 2.0 RC1

phpBB Group phpBB 2.0 RC3

phpBB Group phpBB 2.0 RC4

phpBB Group phpBB 2.0 Beta 1

phpBB Group phpBB 2.0 RC2

phpBB Group phpBB 2.0 .0

phpBB Group phpBB 2.0.1

phpBB Group phpBB 2.0.2

phpBB Group phpBB 2.0.3

phpBB Group phpBB 2.0.4

phpBB Group phpBB 2.0.5

phpBB Group phpBB 2.0.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站