发布时间 :2003-10-30 00:00:00
修订时间 :2008-09-05 16:36:17

[原文]Cross-site scripting (XSS) vulnerability in index.php for LedForums Beta 1 allows remote attackers to inject arbitrary web script or HTML via the (1) top_message parameter or (2) topic field of a new thread.

[CNNVD]Ledscripts LedForums多个字段HTML注入漏洞(CNNVD-200310-091) LedForums Beta 1版本中的index.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过(1)top_message参数或(2)新线程的主题字段来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  ledforums-topicfield-redirect(13563)
(VENDOR_ADVISORY)  XF  ledforums-indexphp-xss(13562)
(UNKNOWN)  BID  8934
(VENDOR_ADVISORY)  BUGTRAQ  20031030 Multiple Vulnerabilities in Led-Forums

- 漏洞信息

Ledscripts LedForums多个字段HTML注入漏洞
中危 跨站脚本
2003-10-30 00:00:00 2005-10-20 00:00:00
远程  LedForums Beta 1版本中的index.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过(1)top_message参数或(2)新线程的主题字段来注入任意Web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (23313)

Ledscripts LedForums Multiple Fileds HTML Injection Vulnerability (EDBID:23313)
php webapps
2003-10-30 Verified
0 ProXy
N/A [点击下载]

It has been reported that LedForums is prone to a HTML injection vulnerability that may allow an attacker to execute HTML code in a user's browser. The issue is reported to be present in the 'top_message' and 'topic' fields. This problem is due to insufficient sanitization of user-supplied input.

Successful exploitation of this vulnerability may allow an attacker to steal cookie-based authentication credentials. Other attacks are also possible.

LedForums Beta 1 has been reported to be vulnerable to this issue.<script>alert(document.cookie)</script><h1>OWNED?%20*g*</h1>


- 漏洞信息

LedForums index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

LedForums contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "top_message" variable upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-10-31 Unknow
Unknow Unknow

- 解决方案




Beta 1

- 相关参考

- 漏洞作者

Unknown or Incomplete