CVE-2003-1194
CVSS6.8
发布时间 :2003-10-30 00:00:00
修订时间 :2008-09-05 16:36:17
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Booby .1 through 0.2.3 allows remote attackers to inject arbitrary web script or HTML via the error message.


[CNNVD]Booby错误信息跨站脚本(XSS)漏洞(CNNVD-200310-090)

        Booby .1到0.2.3版本存在跨站脚本(XSS)漏洞。远程攻击者可以通过错误信息来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:booby:booby:0.2
cpe:/a:booby:booby:0.1.3
cpe:/a:booby:booby:0.1.2
cpe:/a:booby:booby:0.2.3
cpe:/a:booby:booby:0.2.2
cpe:/a:booby:booby:0.1
cpe:/a:booby:booby:0.3
cpe:/a:booby:booby:0.1.1
cpe:/a:booby:booby:0.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1194
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1194
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-090
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/8932
(PATCH)  BID  8932
http://securitytracker.com/id?1008056
(PATCH)  SECTRACK  1008056
http://secunia.com/advisories/10110
(PATCH)  SECUNIA  10110
http://xforce.iss.net/xforce/xfdb/13557
(UNKNOWN)  XF  booby-error-message-xss(13557)
http://sourceforge.net/project/shownotes.php?release_id=193878
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=193878

- 漏洞信息

Booby错误信息跨站脚本(XSS)漏洞
中危 跨站脚本
2003-10-30 00:00:00 2005-10-20 00:00:00
远程  
        Booby .1到0.2.3版本存在跨站脚本(XSS)漏洞。远程攻击者可以通过错误信息来注入任意Web脚本或HTML。

- 公告与补丁

        The vendor has released version 0.2.4 to address this issue:
        Booby Booby 0.0.1
        
        Booby Booby 0.0.2
        
        Booby Booby 0.0.3
        
        Booby Booby 0.1
        
        Booby Booby 0.1.1
        
        Booby Booby 0.1.2
        
        Booby Booby 0.1.3
        
        Booby Booby 0.2
        
        Booby Booby 0.2.1
        
        Booby Booby 0.2.2
        
        Booby Booby 0.2.3
        

- 漏洞信息

2740
Booby Error Message XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Booby prior to version 0.2.4 contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input upon submission. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-10-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站