CVE-2003-1187
CVSS6.8
发布时间 :2003-11-02 00:00:00
修订时间 :2008-09-05 16:36:16
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in include.php in PHPKIT 1.6.02 and 1.6.03 allows remote attackers to inject arbitrary web script or HTML via the contact_email parameter.


[CNNVD]PHPKit Include.PHP跨站脚本(XSS)漏洞(CNNVD-200311-002)

        PHPKIT 1.6.02和1.6.03版本中的include.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过contact_email参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpkit:phpkit:1.6.03
cpe:/a:phpkit:phpkit:1.6.02

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1187
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1187
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-002
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/13590
(VENDOR_ADVISORY)  XF  phpkit-include-xss(13590)
http://www.securityfocus.com/bid/8960
(UNKNOWN)  BID  8960
http://lists.grok.org.uk/pipermail/full-disclosure/2003-November/013139.html
(VENDOR_ADVISORY)  FULLDISC  20031102 [bWM#017] Cross-Site-Scripting @ PHPKIT
http://badwebmasters.net/advisory/017/
(VENDOR_ADVISORY)  MISC  http://badwebmasters.net/advisory/017/

- 漏洞信息

PHPKit Include.PHP跨站脚本(XSS)漏洞
中危 跨站脚本
2003-11-02 00:00:00 2005-10-20 00:00:00
远程  
        PHPKIT 1.6.02和1.6.03版本中的include.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过contact_email参数注入任意Web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (23333)

PHPKit 1.6 Include.PHP Cross-Site Scripting Vulnerability (EDBID:23333)
php webapps
2003-11-02 Verified
0 ben.moeckel@badwebmasters.net
N/A [点击下载]
source: http://www.securityfocus.com/bid/8960/info

PHPKIT is reported to be prone to a cross-site scripting vulnerability. This is due to insufficient sanitization of HTML from URI parameters, which will be displayed in web pages that are dynamically generated by the software. The issue exists in the 'include.php' script.

An attacker could exploit this issue by enticing a user to follow a malicious link. This could theoretically allow for theft of cookie-based authentication credentials or other attacks. 

http://www.example.com/include.php?path=contact.php&contact_email="><script>alert(123);</script> 		

- 漏洞信息

17160
PHPKIT include.php contact_email Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

- 时间线

2003-11-02 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站