CVE-2003-1181
CVSS5.0
发布时间 :2003-10-25 00:00:00
修订时间 :2008-09-05 16:36:15
NMCOE    

[原文]Advanced Poll 2.0.2 allows remote attackers to obtain sensitive information via an HTTP request to info.php, which invokes the phpinfo() function.


[CNNVD]Advanced Poll PHP多个安全漏洞(CNNVD-200310-075)

        
        Advanced Poll是一款基于PHP的投票程序。
        Advanced Poll由于不正确处理用户提交输入,远程攻击者可以利用这些漏洞获得敏感信息,包含远程PHP文件,或者执行PHP代码。
        Advanced Poll包含的comments.php脚本对用户提交给'id'或'template_set'或'action'的变量缺少充分过滤,提交恶意PHP代码可导致以WEB权限执行。
        'admin/common.inc.php'脚本对用户提交的'basepath'变量缺少充分过滤,包含远程服务器上的任意文件,可导致以WEB权限执行任意命令。此脚本对&pollvars[lang]参数也没有正确过滤,提交包含多个'../'的数据可以WEB权限查看系统任意文件内容。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1181
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1181
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200310-075
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/342493
(PATCH)  BUGTRAQ  20031025 Advanced Poll : PHP Code Injection, File Include, Phpinfo
http://xforce.iss.net/xforce/xfdb/13515
(VENDOR_ADVISORY)  XF  advancedpoll-phpinfo-obtain-information(13515)
http://www.securityfocus.com/bid/8890
(VENDOR_ADVISORY)  BID  8890
http://www.osvdb.org/3292
(VENDOR_ADVISORY)  OSVDB  3292
http://secunia.com/advisories/10068
(VENDOR_ADVISORY)  SECUNIA  10068

- 漏洞信息

Advanced Poll PHP多个安全漏洞
中危 输入验证
2003-10-25 00:00:00 2006-08-16 00:00:00
远程  
        
        Advanced Poll是一款基于PHP的投票程序。
        Advanced Poll由于不正确处理用户提交输入,远程攻击者可以利用这些漏洞获得敏感信息,包含远程PHP文件,或者执行PHP代码。
        Advanced Poll包含的comments.php脚本对用户提交给'id'或'template_set'或'action'的变量缺少充分过滤,提交恶意PHP代码可导致以WEB权限执行。
        'admin/common.inc.php'脚本对用户提交的'basepath'变量缺少充分过滤,包含远程服务器上的任意文件,可导致以WEB权限执行任意命令。此脚本对&pollvars[lang]参数也没有正确过滤,提交包含多个'../'的数据可以WEB权限查看系统任意文件内容。
        

- 公告与补丁

        厂商补丁:
        Proxy2.de
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://proxy2.de/scripts.php

- 漏洞信息 (22412)

Advanced Poll 2.0 Remote Information Disclosure Vulnerability (EDBID:22412)
php webapps
2003-03-22 Verified
0 subj
N/A [点击下载]
source: http://www.securityfocus.com/bid/7171/info

It has been reported that an information disclosure vulnerability exists in Advanced Poll. Because of this, a remote user to potentially access privileged information that could lead to further attack against the host and it's users.

http://www.example.com/[poll_dir]/db/info.php
http://www.example.com/[poll_dir]/textfile/info.php		

- 漏洞信息

3292
Advanced Poll info.php System Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Solution Unknown

- 漏洞描述

The PHP web application, Advanced Poll, contains a flaw that may allow a malicious user to sensitive information about the server. The issue is triggered when a request is made to the misc/info.php script that is included with a standard installation. This script simply executes the phpinfo() function and displays the results. It is possible that the flaw may allow an unauthorized remote user to view server path information, environment variables, and internal version numbers of installed libraries.

- 时间线

2003-10-25 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站