CVE-2003-1170
CVSS7.2
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:13
NMCO    

[原文]Format string vulnerability in main.cpp in kpopup 0.9.1 and 0.9.5pre2 allows local users to cause a denial of service (segmentation fault) and possibly execute arbitrary code via format string specifiers in command line arguments.


[CNNVD]kpopup本地参数格式串处理漏洞(CNNVD-200312-476)

        
        Kpopup是一款KDE程序,用于发送和接收MS Windows WinPopup消息的程序。
        Kpopup程序不正确处理用户提交的参数,本地攻击者可以利用这个漏洞进行格式串攻击,可能以root用户权限在系统上执行任意指令。
        格式串问题存在于main.cpp源代码56到60行中的sprintf()函数中,攻击者提交格式字符串作为参数,可导致内存破坏而崩溃,精心构建提交数据可能以root用户权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gernot_stocker:kpopup:0.9.1
cpe:/a:gernot_stocker:kpopup:0.9.5_pre2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1170
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1170
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-476
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/342736
(PATCH)  BUGTRAQ  20031028 Local root vuln in kpopup
http://secunia.com/advisories/10105
(PATCH)  SECUNIA  10105
http://www.securityfocus.com/bid/8918
(UNKNOWN)  BID  8918
http://www.osvdb.org/3290
(UNKNOWN)  OSVDB  3290

- 漏洞信息

kpopup本地参数格式串处理漏洞
高危 输入验证
2003-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        Kpopup是一款KDE程序,用于发送和接收MS Windows WinPopup消息的程序。
        Kpopup程序不正确处理用户提交的参数,本地攻击者可以利用这个漏洞进行格式串攻击,可能以root用户权限在系统上执行任意指令。
        格式串问题存在于main.cpp源代码56到60行中的sprintf()函数中,攻击者提交格式字符串作为参数,可导致内存破坏而崩溃,精心构建提交数据可能以root用户权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Gernot Stocker
        --------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.henschelsoft.de/kpopup_en.html

- 漏洞信息

3290
KPopup main.cpp Format String Privilege Escalation
Local Access Required, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Kpopup contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when a malicous user passes a carefully crafted format string argument to the kpopup executable. This flaws may be abused to execute arbitrary code as the root user.

- 时间线

2003-10-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.6pre1 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: remove the SUID bit from the kpopup utility

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站