发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:12

[原文]Cross-site scripting (XSS) vulnerability in Mldonkey 2.5-4 allows remote attackers to inject arbitrary web script or HTML via the URI, which is injected into the HTML error page.

[CNNVD]Mldonkey Web界面错误消息跨站脚本漏洞(CNNVD-200312-117)

        Mldonkey 2.5-4版本存在跨站脚本(XSS)漏洞。远程攻击者借助URI注入任意web脚本或者HTML,并且注入到HTML出错页中。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  mldonkey-xss(13615)
(UNKNOWN)  BID  8946
(UNKNOWN)  FULLDISC  20031031 XSS In mldonkey - But....

- 漏洞信息

Mldonkey Web界面错误消息跨站脚本漏洞
中危 跨站脚本
2003-12-31 00:00:00 2005-10-20 00:00:00
        Mldonkey 2.5-4版本存在跨站脚本(XSS)漏洞。远程攻击者借助URI注入任意web脚本或者HTML,并且注入到HTML出错页中。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (23320)

Mldonkey 2.5 -4 Web Interface Error Message Cross-site Scripting Vulnerability (EDBID:23320)
multiple remote
2003-10-31 Verified
0 Chris Sharp
N/A [点击下载]

It has been reported that the Mldonkey web interface is prone to cross-site scripting attacks when reporting errors. The problem occurs due to insufficient sanitization of script code within requests. This could potentially allow an attacker to carry out a variety of attacks on a user.<script>...</script>		

- 漏洞信息

MLdonkey URI Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

MLdonkey for Mac OS X, Unix and Linux contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input variables upon submission of an incoming request. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-11-05 2003-11-05
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete