CVE-2003-1163
CVSS5.0
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:36:12
NMCO    

[原文]hash.c in Ganglia gmond 2.5.3 allows remote attackers to cause a denial of service (segmentation fault) via a UDP packet that contains a single-byte name string, which is used as an out-of-bounds array index.


[CNNVD]Ganglia gmond畸形数据包远程服务拒绝漏洞(CNNVD-200312-328)

        Ganglia gmond 2.5.3版本的hash.c存在漏洞。远程攻击者可以借助含单字节名称字符串的UDP数据包导致服务拒绝(分段错误),该漏洞被用作越界数组索引。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ganglia:gmond:2.5.0
cpe:/a:ganglia:gmond:2.5.3
cpe:/a:ganglia:gmond:2.5.1
cpe:/a:ganglia:gmond:2.5.4
cpe:/a:ganglia:gmond:2.5.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1163
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1163
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-328
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/10166
(PATCH)  SECUNIA  10166
http://xforce.iss.net/xforce/xfdb/13631
(UNKNOWN)  XF  ganglia-gmond-dos(13631)
http://www.securityfocus.com/bid/8988
(UNKNOWN)  BID  8988
http://www.securityfocus.com/archive/1/343689
(UNKNOWN)  BUGTRAQ  20031106 DoS for Ganglia
http://www.osvdb.org/2787
(UNKNOWN)  OSVDB  2787
http://ganglia.sourceforge.net/
(UNKNOWN)  CONFIRM  http://ganglia.sourceforge.net/

- 漏洞信息

Ganglia gmond畸形数据包远程服务拒绝漏洞
中危 其他
2003-12-31 00:00:00 2005-10-20 00:00:00
远程  
        Ganglia gmond 2.5.3版本的hash.c存在漏洞。远程攻击者可以借助含单字节名称字符串的UDP数据包导致服务拒绝(分段错误),该漏洞被用作越界数组索引。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

2787
Ganglia gmond hash.c Malcrafted UDP Packet Handling Remote DoS
Denial of Service
Loss of Availability

- 漏洞描述

Ganglia contains a flaw that may allow a remote denial of service. The issue is triggered when gmond is supplied with certain bad UDP packets, and will result in loss of availability for the service.

- 时间线

2003-11-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.5.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站