发布时间 :2003-11-03 00:00:00
修订时间 :2008-09-05 16:36:09

[原文]Cross-site scripting (XSS) vulnerability in friendmail.php in OpenAutoClassifieds 1.0 allows remote attackers to inject arbitrary web script or HTML via the listing parameter.

[CNNVD]OpenAutoClassifieds Listing参数跨站脚本(XSS)漏洞(CNNVD-200311-024)

        OpenAutoClassifieds 1.0版本中的friendmail.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过listing参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  openautoclassifieds-friendmail-xss(13604)
(VENDOR_ADVISORY)  BUGTRAQ  20031107 OpenAutoClassifieds XSS attack

- 漏洞信息

OpenAutoClassifieds Listing参数跨站脚本(XSS)漏洞
中危 跨站脚本
2003-11-03 00:00:00 2005-10-20 00:00:00
        OpenAutoClassifieds 1.0版本中的friendmail.php存在跨站脚本(XSS)漏洞。远程攻击者可以通过listing参数注入任意web脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (23336)

OpenAutoClassifieds 1.0 Listing Parameter Cross-Site Scripting Vulnerability (EDBID:23336)
php webapps
2003-11-04 Verified
0 David Sopas Ferreira
N/A [点击下载]

It has been reported that OpenAutoClassifieds is prone to a cross-site scripting vulnerability. The issue is reported to exist due insufficient sanitization of user-supplied data through the 'listings' parameter. The problem may allow a remote attacker to execute HTML or script code in the browser of a user following a malicious link created by an attacker.

Successful exploitation of this attack may allow an attacker to steal cookie-based authentication information that could be used to launch further attacks.

OpenAutoClassifieds version 1.0 is reported to be prone to this issue, however other versions may be affected as well.<

- 漏洞信息

OpenAutoClassifieds friendmail.php listing Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

OpenAutoClassifieds contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "listing" variable upon submission to the friendmail.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-11-04 Unknow
2003-11-04 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround(s): Modify the script 'friendmail.php' to validate the contents of the 'listing' variable, escaping all special characters.

- 相关参考

- 漏洞作者

Unknown or Incomplete