CVE-2003-1144
CVSS10.0
发布时间 :2003-11-04 00:00:00
修订时间 :2008-09-05 16:36:09
NMCO    

[原文]Buffer overflow in the log viewing interface in Perception LiteServe 1.25 through 2.2 allows remote attackers to execute arbitrary code via a GET request with a long file name.


[CNNVD]Perception LiteServe Server日志远程缓冲区溢出漏洞(CNNVD-200311-028)

        
        LiteServe是一款强大的集合Web、Mail、FTP和Telnet服务的程序。
        LiteServe不正确处理用户提交的超长文件名请求,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以LiteServe进程权限在系统上执行任意指令。
        如果攻击者提交超长文件名的HTTP GET请求,当管理员查看服务器日志,使用LiteServer接口点击请求时,可触发缓冲区溢出,覆盖堆栈中的返回地址,精心构建提交数据可能以LiteServe进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:perception:liteserve:2.2
cpe:/a:perception:liteserve:2.0.1
cpe:/a:perception:liteserve:2.0
cpe:/a:perception:liteserve:2.0.2
cpe:/a:perception:liteserve:1.28
cpe:/a:perception:liteserve:1.25

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1144
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1144
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-028
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/2766
(VENDOR_ADVISORY)  OSVDB  2766
http://secunia.com/advisories/10136
(VENDOR_ADVISORY)  SECUNIA  10136
http://xforce.iss.net/xforce/xfdb/13599
(VENDOR_ADVISORY)  XF  liteserve-log-entry-bo(13599)
http://www.securityfocus.com/bid/8971
(VENDOR_ADVISORY)  BID  8971
http://www.securityfocus.com/archive/1/343322
(VENDOR_ADVISORY)  BUGTRAQ  20031104 Liteserve Buffer Overflow in Handling Server's Log.
http://securitytracker.com/id?1008093
(VENDOR_ADVISORY)  SECTRACK  1008093

- 漏洞信息

Perception LiteServe Server日志远程缓冲区溢出漏洞
危急 边界条件错误
2003-11-04 00:00:00 2005-10-20 00:00:00
远程  
        
        LiteServe是一款强大的集合Web、Mail、FTP和Telnet服务的程序。
        LiteServe不正确处理用户提交的超长文件名请求,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以LiteServe进程权限在系统上执行任意指令。
        如果攻击者提交超长文件名的HTTP GET请求,当管理员查看服务器日志,使用LiteServer接口点击请求时,可触发缓冲区溢出,覆盖堆栈中的返回地址,精心构建提交数据可能以LiteServe进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Perception
        ----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.liteserve.net/

- 漏洞信息

2766
Perception LiteServe Long GET Request Log Entry Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

LiteServe versions 2.2 and earlier are vulnerable to a buffer overflow, caused by improper bounds checking of log entries. By sending a long HTTP GET request, a remote attacker could overflow a buffer and possibly execute code on the system, once the log entry is viewed by the administrator.

- 时间线

2003-11-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.21 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站