发布时间 :2003-12-31 00:00:00
修订时间 :2017-07-10 21:29:45

[原文]Buffer overflow in the Yahoo! Audio Conferencing (aka Voice Chat) ActiveX control before 1,0,0,45 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a URL with a long hostname to Yahoo! Messenger or Yahoo! Chat.

[CNNVD]Yahoo! Voice Chat ActiveX控件远程漏洞(CNNVD-200312-431)

        Yahoo! Voice Chat是一款音频聊天程序,以ActiveX控件形式安装。
        Yahoo! Voice Chat ActiveX控件存在一个漏洞,远程攻击者可以利用这个漏洞构建恶意页面,诱使用户访问,触发漏洞。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BUGTRAQ  20030530 Yahoo! Security Advisory: Yahoo! Voice Chat
(UNKNOWN)  BID  7561
(UNKNOWN)  XF  yahoo-audio-bo(12130)

- 漏洞信息

Yahoo! Voice Chat ActiveX控件远程漏洞
低危 边界条件错误
2003-12-31 00:00:00 2005-10-20 00:00:00
        Yahoo! Voice Chat是一款音频聊天程序,以ActiveX控件形式安装。
        Yahoo! Voice Chat ActiveX控件存在一个漏洞,远程攻击者可以利用这个漏洞构建恶意页面,诱使用户访问,触发漏洞。

- 公告与补丁

        * 暂时删除Yahoo! Voice Chat ActiveX控件:
        ystemroot%\Downloaded Program Files\
        Yahoo Audio Conferencing
        Yahoo Audio UI1

- 漏洞信息 (22593)

Yahoo! Voice Chat ActiveX Control 1.0 .0.43 Buffer Overflow Vulnerability (EDBID:22593)
windows remote
2003-05-12 Verified
0 cesaro
N/A [点击下载]

It has been reported that the ActiveX control used by the Yahoo! Voice Chat feature is prone to an exploitable buffer overflow vulnerability. This issue can be exploited via a malicious web page that calls the vulnerable control with malformed parameters. Although unconfirmed, it has been conjectured that this condition may be exploited to execute arbitrary code. 

<OBJECT id=yahooaudio type="application/x-oleobject"


- 漏洞信息

Yahoo! Audio Conferencing ActiveX Control Overflow
Remote / Network Access, Context Dependent Input Manipulation
Loss of Integrity, Loss of Availability

- 漏洞描述

Yahoo! Audio Conferencing contains a flaw that may allow a remote attacker to execute arbitrary code. The issue is due to an unchecked buffer in the Audio Conferencing ActiveX Control. If an attacker sends a specially crafted request, they may be able to overflow the buffer and execute arbitrary code.

- 时间线

2003-05-30 2003-05-12
Unknow Unknow

- 解决方案

Upgrade to version 1,0,0,45 or higher (pushed automatically upon connection), as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: The control can be disabled by removing the object from the Internet Explorer "Downloaded Program Files" cache and, if Yahoo! Messenger is installed, going into the Yahoo! Messenger directory (by default, C:\Program Files\Yahoo!\Messenger\) and running the following command: regsvr32 /u yacscom.dll

- 相关参考

- 漏洞作者