CVE-2003-1097
CVSS7.2
发布时间 :2003-12-31 00:00:00
修订时间 :2009-03-04 00:19:41
NMCOE    

[原文]Buffer overflow in rexec on HP-UX B.10.20, B.11.00, and B.11.04, when setuid root, may allow local users to gain privileges via a long -l option.


[CNNVD]HP-UX rexec本地缓冲区溢出漏洞(CNNVD-200312-420)

        
        HP-UX是惠普公司开发和维护的商业性质UNIX操作系统。
        HP-UX包含的rexec命令对用户提交的参数缺少充分的边界检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以root用户权限在系统上执行任意指令。
        rexec命令类似remsh命令工作,可以远程在受信站点上执行命令,不过它使用rexe()库函数和rexecd来执行命令,不支持Kerberos验证。其中"-l"选项用于指定不同的远程用户名,rexec命令对"-l"选项参数的值缺少正确边界缓冲区检查,攻击者提交超长的字符串作为参数数据,可以导致出现内存错误,精心构建提交字符串可能以root用户权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:hp:hp-ux:10.30HP HP-UX 10.30
cpe:/o:hp:hp-ux:10.24HP HP-UX 10.24
cpe:/o:hp:hp-ux:11.22HP-UX 11i v1.6
cpe:/o:hp:hp-ux:11.04HP HP-UX 11.04
cpe:/o:hp:hp-ux:11.20HP-UX 11i v1.5
cpe:/o:hp:hp-ux:10.26HP HP-UX 10.26
cpe:/o:hp:hp-ux:11.00HP-UX 11.00
cpe:/o:hp:hp-ux:10.16HP HP-UX 10.16
cpe:/o:hp:hp-ux:10.10HP HP-UX 10.10
cpe:/o:hp:hp-ux:10.20HP HP-UX 10.20
cpe:/o:hp:hp-ux:11.11HP-UX 11.11
cpe:/o:hp:hp-ux:10.34HP HP-UX 10.34

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:5611Potential buffer overflow in rexec(1)
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1097
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1097
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-420
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/CRDY-5MJKM4
(VENDOR_ADVISORY)  HP  HPSBUX0304-257
http://www.kb.cert.org/vuls/id/322540
(VENDOR_ADVISORY)  CERT-VN  VU#322540
http://www.securityfocus.com/bid/7459
(PATCH)  BID  7459
http://www.ciac.org/ciac/bulletins/n-088.shtml
(PATCH)  CIAC  N-088
http://xforce.iss.net/xforce/xfdb/11890
(UNKNOWN)  XF  hp-rexec-command-bo(11890)
http://archives.neohapsis.com/archives/bugtraq/2003-04/0374.html
(UNKNOWN)  BUGTRAQ  20030429 HPUX rexec buffer overflow vulnerability

- 漏洞信息

HP-UX rexec本地缓冲区溢出漏洞
高危 边界条件错误
2003-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        HP-UX是惠普公司开发和维护的商业性质UNIX操作系统。
        HP-UX包含的rexec命令对用户提交的参数缺少充分的边界检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以root用户权限在系统上执行任意指令。
        rexec命令类似remsh命令工作,可以远程在受信站点上执行命令,不过它使用rexe()库函数和rexecd来执行命令,不支持Kerberos验证。其中"-l"选项用于指定不同的远程用户名,rexec命令对"-l"选项参数的值缺少正确边界缓冲区检查,攻击者提交超长的字符串作为参数数据,可以导致出现内存错误,精心构建提交字符串可能以root用户权限在系统上执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * chmod -s 去掉相关S位。
        厂商补丁:
        HP
        --
        HP已经为此发布了一个安全公告(HPSBUX0304-257)以及相应补丁:
        HPSBUX0304-257:SSRT3496 Potential Security Vulnerability in rexec
        根据公告下载和安装libc.1.10.20。
        rexec@hprc.external.hp.com/" target="_blank">ftp://rexec:rexec@hprc.external.hp.com/
        ftp://rexec:rexec@192.170.19.51/
        HP HP-UX 11.0:
         HP Patch PHCO_24723
        
        http://itrc.hp.com/

- 漏洞信息 (22552)

HP-UX 10.x/11.x RExec Remote Username Flag Local Buffer Overrun Vulnerability (EDBID:22552)
hp-ux dos
2003-04-29 Verified
0 Davide Del Vecchio
N/A [点击下载]
source: http://www.securityfocus.com/bid/7459/info

It has been reported that a problem in the rexec program included with some versions of HP-UX may be vulnerable to a boundary condition error. It may be possible for a local user to exploit this vulnerability to gain elevated privileges on the system. 

exec 127.0.0.1 -l `perl -e 'printf "A" x 9777'` -n something		

- 漏洞信息

16021
HP-UX inrexec -l Option Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2003-04-29 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站