CVE-2003-1095
CVSS4.6
发布时间 :2003-03-18 00:00:00
修订时间 :2008-09-05 16:36:01
NMCO    

[原文]BEA WebLogic Server and Express 7.0 and 7.0.0.1, when using "memory" session persistence for web applications, does not clear authentication information when a web application is redeployed, which could allow users of that application to gain access without having to re-authenticate.


[CNNVD]BEA WebLogic Web应用程序验证可绕过漏洞(CNNVD-200303-053)

        
        BEA Systems WebLogic包含多种系统集成方案,包括Server/Express/Integration等。
        BEA WebLogic Web应用程序组件实现的会话持续功能存在漏洞,远程攻击者利用这个漏洞未授权访问WebLogic服务器。
        当应用程序包含的WEB应用程序组件使用"memory"会话持续没有通过重启服务器来重新配置,之前登录进WEB应用程序的用户就不需要验证再次访问,即使用户已经离最后一次访问很长时间也能进行登录。
        只有使用WEB应用程序,"memory"会话持续和动态重配置(即不重启进行重新配置)的系统才受此漏洞影响。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:bea:weblogic_server:7.0.0.1::win32
cpe:/a:bea:weblogic_server:7.0::win32
cpe:/a:bea:weblogic_server:7.0.0.1:sp1BEA Systems WebLogic Server 7.0.0.1 SP1
cpe:/a:bea:weblogic_server:7.0:sp1
cpe:/a:bea:weblogic_server:7.0BEA Systems WebLogic Server 7.0
cpe:/a:bea:weblogic_server:7.0:sp1:win32
cpe:/a:bea:weblogic_server:7.0.0.1BEA Systems WebLogic Server 7.0.0.1
cpe:/a:bea:weblogic_server:7.0.0.1:sp1:win32BEA Systems WebLogic Server 7.0.0.1 SP1 Win32

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1095
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1095
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200303-053
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/691153
(VENDOR_ADVISORY)  CERT-VN  VU#691153
http://xforce.iss.net/xforce/xfdb/11555
(VENDOR_ADVISORY)  XF  weblogic-app-reauthentication-bypass(11555)
http://www.securityfocus.com/bid/7130
(VENDOR_ADVISORY)  BID  7130

- 漏洞信息

BEA WebLogic Web应用程序验证可绕过漏洞
中危 设计错误
2003-03-18 00:00:00 2005-10-20 00:00:00
远程  
        
        BEA Systems WebLogic包含多种系统集成方案,包括Server/Express/Integration等。
        BEA WebLogic Web应用程序组件实现的会话持续功能存在漏洞,远程攻击者利用这个漏洞未授权访问WebLogic服务器。
        当应用程序包含的WEB应用程序组件使用"memory"会话持续没有通过重启服务器来重新配置,之前登录进WEB应用程序的用户就不需要验证再次访问,即使用户已经离最后一次访问很长时间也能进行登录。
        只有使用WEB应用程序,"memory"会话持续和动态重配置(即不重启进行重新配置)的系统才受此漏洞影响。
        

- 公告与补丁

        厂商补丁:
        BEA Systems
        -----------
        目前厂商已经发布了升级补丁以修复这个安全问题,建议用户升级到最新的Service Pack:
        
        http://commerce.beasys.com/downloads/weblogic_server.jsp#wls

- 漏洞信息

16025
BEA WebLogic Memory Session Persistence Admin Authentication Bypass
Remote / Network Access Authentication Management
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-03-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 7.0 SP2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站