发布时间 :2004-02-17 00:00:00
修订时间 :2008-09-05 16:35:51

[原文]Cross-site scripting (XSS) vulnerability in register.php for vBulletin 3.0 Beta 2 allows remote attackers to inject arbitrary HTML or web script via optional fields such as (1) "Interests-Hobbies", (2) "Biography", or (3) "Occupation."

[CNNVD]vBulletin register.php跨站脚本(XSS)漏洞(CNNVD-200402-066)

        vBulletin 3.0 Beta 2中的register.php存在跨站脚本(XSS)漏洞。远程攻击者借助例如(1) "Interests-Hobbies", (2) "Biography",或者(3) "Occupation."的选项字段注入任意HTML或者web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  VULNWATCH  20030808 VBulletin New Member XSS Vulnerability

- 漏洞信息

vBulletin register.php跨站脚本(XSS)漏洞
中危 跨站脚本
2004-02-17 00:00:00 2005-10-20 00:00:00
        vBulletin 3.0 Beta 2中的register.php存在跨站脚本(XSS)漏洞。远程攻击者借助例如(1) "Interests-Hobbies", (2) "Biography",或者(3) "Occupation."的选项字段注入任意HTML或者web脚本。

- 公告与补丁


- 漏洞信息 (22990)

vBulletin 3.0 Register.PHP HTML Injection Vulnerability (EDBID:22990)
php webapps
2003-08-06 Verified
0 Ferruh Mavituna
N/A [点击下载]

vBulletin may be prone to an HTML injection vulnerability. This issue is exposed through inadequate sanitization of user input for certain fields within the register.php script. An attacker may exploit this issue by including hostile HTML and script code in fields that may be displayed in posts to the message board, or the user's profile. This code may be rendered in the web browser of a user who views the malicious message.

[form action="http://[victim]/register.php?do=register" method="post"
[input type="hidden" name="s" value="" /]
[input type="hidden" name="regtype" value="1" /]
[input type="text" class="bginput" name="field1" value="" size="25"
maxlength="250" /]
[input type="hidden" name="url" value="index.php" /]
[input type="hidden" name="do" value="addmember" /] 
//Code that will be executed
var xss = "\"][script]alert(document"+".cookie)[\/script]";

*Replace ([],<>)		

- 漏洞信息

vBulletin register.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

vBulletin contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "method" or "style" variables upon submission to the register.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2003-08-08 Unknow
2003-08-08 Unknow

- 解决方案

Upgrade to version vBulletin 23.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者