CVE-2003-1021
CVSS7.2
发布时间 :2005-01-26 00:00:00
修订时间 :2008-09-05 16:35:49
NMCOS    

[原文]The scosession program in OpenServer 5.0.6 and 5.0.7 allows local users to gain privileges via crafted strings on the commandline.


[CNNVD]SCO OpenServer scosession 本地权限提升漏洞(CNNVD-200501-277)

        SCO Openserver是一套UNIX操作系统。
        OpenServer 5.0.6及5.0.7中的scosession程序存在本地用户权限提升漏洞。
        本地用户可以通过命令行方式,以特殊构造的字符串获取系统权限。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-1021
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-1021
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-277
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/972598
(VENDOR_ADVISORY)  CERT-VN  VU#972598
http://xforce.iss.net/xforce/xfdb/19479
(VENDOR_ADVISORY)  XF  openserver-scosession-gain-privilege(19479)
http://secunia.com/advisories/14012/
(VENDOR_ADVISORY)  SECUNIA  14012
http://www.securityfocus.com/bid/12372
(VENDOR_ADVISORY)  BID  12372
ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2005.5/SCOSA-2005.5.txt
(UNKNOWN)  SCO  SCOSA-2005.5

- 漏洞信息

SCO OpenServer scosession 本地权限提升漏洞
高危 边界条件错误
2005-01-26 00:00:00 2005-10-20 00:00:00
本地  
        SCO Openserver是一套UNIX操作系统。
        OpenServer 5.0.6及5.0.7中的scosession程序存在本地用户权限提升漏洞。
        本地用户可以通过命令行方式,以特殊构造的字符串获取系统权限。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:ftp://ftp.sco.com/pub/updates/OpenServer/SCOSA-2005.5/SCOSA-2005.5.txt

- 漏洞信息

13200
SCO OpenServer scosession Local Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-25 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SCO scosession Local Command Line Buffer Overflow Vulnerability
Boundary Condition Error 12372
No Yes
2005-01-26 12:00:00 2009-07-12 10:06:00
The individual or individuals responsible for the discovery of this issue are currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

SCO Open Server 5.0.7
SCO Open Server 5.0.6 a
SCO Open Server 5.0.6
SCO Open Server 5.0.5
SCO Open Server 5.0.4
SCO Open Server 5.0.3
SCO Open Server 5.0.2
SCO Open Server 5.0.1
SCO Open Server 5.0

- 漏洞讨论

A local buffer overflow vulnerability affects SCO scosession. This issue is due to a failure of the application to properly validate user-supplied input strings prior to copying them to finite process buffers.

A local attacker may leverage this issue to execute arbitrary code with the privileges of the superuser, facilitating privilege escalation.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

SCO has made an advisory available dealing with this issue. Please see the referenced advisory for more information.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站