CVE-2003-0969
CVSS7.5
发布时间 :2004-01-20 00:00:00
修订时间 :2013-08-20 00:27:23
NMCOS    

[原文]mpg321 0.2.10 allows remote attackers to overwrite memory and possibly execute arbitrary code via an mp3 file that passes certain strings to the printf function, possibly triggering a format string vulnerability.


[CNNVD]mpg321 MP3 文件远程格式字符串漏洞(CNNVD-200401-036)

        mpg321 0.2.10版本存在漏洞。远程攻击者可能通过传递某些字符串到printf函数的mp3文件执行任意代码,可能触发格式字符串漏洞。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0969
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0969
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200401-036
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/14148
(VENDOR_ADVISORY)  XF  mpg321-mp3-format-string(14148)
http://www.securityfocus.com/bid/9364
(VENDOR_ADVISORY)  BID  9364
http://www.osvdb.org/3331
(UNKNOWN)  OSVDB  3331
http://www.novell.com/linux/security/advisories/2004_02_tcpdump.html
(UNKNOWN)  SUSE  SuSE-SA:2004:002
http://www.debian.org/security/2004/dsa-411
(UNKNOWN)  DEBIAN  DSA-411

- 漏洞信息

mpg321 MP3 文件远程格式字符串漏洞
高危 格式化字符串
2004-01-20 00:00:00 2006-09-21 00:00:00
远程  
        mpg321 0.2.10版本存在漏洞。远程攻击者可能通过传递某些字符串到printf函数的mp3文件执行任意代码,可能触发格式字符串漏洞。

- 公告与补丁

        Debian has released advisory DSA 411-1 to address this issue. Please see the attached advisory for details on obtaining and applying fixes.
        Gentoo Linux has released advisory GLSA 200503-34 dealing with this issue. Gentoo advises that all users carry out the following commands with superuser privileges to update their packages:
        emerge --sync
         emerge --ask --oneshot --verbose ">=media-sound/mpg321-0.2.10-r2"
        For more information, please see the referenced Gentoo linux advisory.
        mpg321 mpg321 0.2.10
        

- 漏洞信息

3331
mpg321 Remotely Exploitable
Remote / Network Access

- 漏洞描述

A remote overflow exists in mpg321. The package fails to validate some striugs within an MP3 file resulting in a printf() overflow. With a specially crafted MP3 file, an attacker can cause execution of arbitrary code resulting in a loss of integrity and/or availability.

- 时间线

2004-01-06 Unknow
Unknow Unknow

- 解决方案

For the current stable Debian distribution (woody) upgrade to mpg321 version 0.2.10.2. For the unstable distribution (sid) upgrade to mpg321 version 0.2.10.3. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

mpg321 MP3 File Remote Format String Vulnerability
Input Validation Error 9364
Yes No
2004-01-06 12:00:00 2009-07-12 12:56:00
This issue was announced in a Debian advisory.

- 受影响的程序版本

mpg321 mpg321 0.2.10
+ Gentoo Linux
mpg321 mpg321 0.2.9
+ RedHat Linux 7.2
mpg321 mpg321 0.2.3
+ RedHat Linux 7.2
mpg321 mpg321 0.2.2
- Caldera OpenLinux Server 3.1.1
- Caldera OpenLinux Workstation 3.1.1
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
- RedHat Linux 7.2 i386
- RedHat Linux 7.1 i386
- RedHat Linux 7.0 i386
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386
- S.u.S.E. Linux 7.1 x86
- Slackware Linux 8.0
- Slackware Linux 7.1
- Slackware Linux 7.0
mpg321 mpg321 0.1.5
- Caldera OpenLinux Server 3.1.1
- Caldera OpenLinux Workstation 3.1.1
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
+ RedHat Linux 7.2 i386
- RedHat Linux 7.1 i386
- RedHat Linux 7.0 i386
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386
- S.u.S.E. Linux 7.1 x86
- Slackware Linux 8.0
- Slackware Linux 7.1
- Slackware Linux 7.0

- 漏洞讨论

A remotely exploitable format string vulnerability is present in mpg321. This issue could be exploited if a malicious MP3 file is played by a user, either by opening the file manually or by streaming the malicious file. This will permit for execution of arbitrary code in the context of the user invoking the media player.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released advisory DSA 411-1 to address this issue. Please see the attached advisory for details on obtaining and applying fixes.

Gentoo Linux has released advisory GLSA 200503-34 dealing with this issue. Gentoo advises that all users carry out the following commands with superuser privileges to update their packages:

emerge --sync
emerge --ask --oneshot --verbose ">=media-sound/mpg321-0.2.10-r2"

For more information, please see the referenced Gentoo linux advisory.


mpg321 mpg321 0.2.10

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站