CVE-2003-0954
CVSS7.2
发布时间 :2003-12-31 00:00:00
修订时间 :2008-09-05 16:35:38
NMCOS    

[原文]Buffer overflow in rcp for AIX 4.3.3, 5.1 and 5.2 allows local users to gain privileges.


[CNNVD]IBM AIX RCP本地缓冲区溢出漏洞(CNNVD-200312-156)

        
        IBM AIX是一款商业性质UNIX操作系统。
        IBM包含的RCP工具由于在处理命令行或环境数据时缺少正确的边界缓冲区检查,本地攻击者可以利用这个漏洞获得root用户权限。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:ibm:aix:5.1IBM AIX 5.1
cpe:/o:ibm:aix:5.2IBM AIX 5.2
cpe:/o:ibm:aix:4.3.3IBM AIX 4.3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0954
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0954
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-156
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9078
(PATCH)  BID  9078
http://secunia.com/advisories/10276/
(PATCH)  SECUNIA  10276
http://www-1.ibm.com/support/search.wss?rs=0&q=IY49238&apar=only
(UNKNOWN)  AIXAPAR  IY49238
http://www-1.ibm.com/support/search.wss?rs=0&q=IY48747&apar=only
(UNKNOWN)  AIXAPAR  IY48747
http://www-1.ibm.com/support/search.wss?rs=0&q=IY48272&apar=only
(UNKNOWN)  AIXAPAR  IY48272
http://securitytracker.com/id?1008258
(UNKNOWN)  SECTRACK  1008258

- 漏洞信息

IBM AIX RCP本地缓冲区溢出漏洞
高危 边界条件错误
2003-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        IBM AIX是一款商业性质UNIX操作系统。
        IBM包含的RCP工具由于在处理命令行或环境数据时缺少正确的边界缓冲区检查,本地攻击者可以利用这个漏洞获得root用户权限。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        IBM
        ---
        IBM已经提供APARS来修补此问题,具体详细信息可联系供应商获得:
        
        http://www-1.ibm.com/servers/aix/

- 漏洞信息

2852
IBM AIX rcp Local Privilege Escalation

- 漏洞描述

An unspecified local boundary error exists in AIX rcp. With a specially crafted request, an attacker can cause an elevation of privileges resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2003-11-14 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, IBM has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM AIX RCP Utility Local Buffer Overrun Vulnerability
Boundary Condition Error 9078
No Yes
2003-11-20 12:00:00 2009-07-12 12:56:00
This issue was discovered internally by IBM.

- 受影响的程序版本

IBM AIX 4.3.3
IBM AIX 5.2
IBM AIX 5.1

- 漏洞讨论

IBM has announced the existence of a local buffer overrun vulnerability in the rcp utility that could be exploited to gain root privileges. The precise details regarding this condition are unknown, however it is likely that the problem occurs due to insufficient bounds checking when handling command-line or environment data.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

IBM is said to have released APARs to address this issue. Further information can be obtained by contacting the vendor.


IBM AIX 5.1

IBM AIX 5.2

IBM AIX 4.3.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站