发布时间 :2004-02-03 00:00:00
修订时间 :2008-09-05 16:35:38

[原文]xsok 1.02 does not properly drop privileges before finding and executing the "gunzip" program, which allows local users to execute arbitrary commands.



- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  xsok-command-execution(14098)

- 漏洞信息

中危 输入验证
2004-02-03 00:00:00 2005-12-06 00:00:00

- 公告与补丁


- 漏洞信息

xsok gunzip Path Variable Privilege Escalation

- 漏洞描述

Xsok contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered due to an unspecified error.

- 时间线

2003-12-30 Unknow
Unknow Unknow

- 解决方案

Currently, there are no upgrades to correct this issue. However, Debian GNU/Linux has released a patch to address this vulnerability. It is possible to correct the flaw by implementing the following workaround(s): Remove suid or sgid bits.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

XSOK GunZip Path Environment Variable Local Command Execution Vulnerability
Input Validation Error 9321
No Yes
2003-12-30 12:00:00 2009-07-12 12:56:00
Discovery credited to Steve Kemp.

- 受影响的程序版本

xsok xsok 1.0 2
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha

- 漏洞讨论

A problem has been disclosed in the handling of user-supplied input in xsok. Because of this, an attacker may be able to gain elevated privileges on a host with the vulnerable program. The program is typically installed with setgid games privileges.

- 漏洞利用

No exploit is required for this vulnerability.

- 解决方案

Debian has made fixes available to resolve this issue. See Debian advisory DSA 405-1 for additional details.

xsok xsok 1.0 2

- 相关参考