CVE-2003-0927
CVSS7.5
发布时间 :2003-12-01 00:00:00
修订时间 :2010-08-21 00:17:24
NMCO    

[原文]Heap-based buffer overflow in Ethereal 0.9.15 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the SOCKS dissector.


[CNNVD]Ethereal基于堆的缓冲区溢出漏洞(CNNVD-200312-016)

        Ethereal 0.9.15以及之前的版本存在基于堆的缓冲区溢出漏洞。远程攻击者借助SOCKS解剖器导致服务拒绝(崩溃)并可能执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ethereal_group:ethereal:0.9.8
cpe:/a:ethereal_group:ethereal:0.9.7
cpe:/a:ethereal_group:ethereal:0.9
cpe:/a:ethereal_group:ethereal:0.9.11
cpe:/a:ethereal_group:ethereal:0.9.2
cpe:/a:ethereal_group:ethereal:0.9.9
cpe:/a:ethereal_group:ethereal:0.9.14
cpe:/a:ethereal_group:ethereal:0.9.10
cpe:/a:ethereal_group:ethereal:0.9.4
cpe:/a:ethereal_group:ethereal:0.9.5
cpe:/a:ethereal_group:ethereal:0.9.13
cpe:/a:ethereal_group:ethereal:0.9.12
cpe:/a:ethereal_group:ethereal:0.9.15
cpe:/a:ethereal_group:ethereal:0.9.1
cpe:/a:ethereal_group:ethereal:0.9.3
cpe:/a:ethereal_group:ethereal:0.9.6

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9691Heap-based buffer overflow in Ethereal 0.9.15 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute ...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0927
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0927
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200312-016
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/8951
(VENDOR_ADVISORY)  BID  8951
http://www.redhat.com/support/errata/RHSA-2003-323.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:323
http://www.ethereal.com/appnotes/enpa-sa-00011.html
(VENDOR_ADVISORY)  CONFIRM  http://www.ethereal.com/appnotes/enpa-sa-00011.html
http://xforce.iss.net/xforce/xfdb/13578
(UNKNOWN)  XF  ethereal-socks-heap-overflow(13578)
http://www.turbolinux.com/security/TLSA-2003-64.txt
(UNKNOWN)  TURBO  TLSA-2003-64
http://www.redhat.com/support/errata/RHSA-2003-324.html
(UNKNOWN)  REDHAT  RHSA-2003:324
http://www.debian.org/security/2003/dsa-407
(UNKNOWN)  DEBIAN  DSA-407
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000780
(UNKNOWN)  CONECTIVA  CLA-2003:780
http://www.mandriva.com/security/advisories?name=MDKSA-2003:114
(UNKNOWN)  MANDRAKE  MDKSA-2003:114
http://secunia.com/advisories/10531
(UNKNOWN)  SECUNIA  10531

- 漏洞信息

Ethereal基于堆的缓冲区溢出漏洞
高危 缓冲区溢出
2003-12-01 00:00:00 2005-10-20 00:00:00
远程  
        Ethereal 0.9.15以及之前的版本存在基于堆的缓冲区溢出漏洞。远程攻击者借助SOCKS解剖器导致服务拒绝(崩溃)并可能执行任意代码。
        

- 公告与补丁

        

- 漏洞信息

2752
Ethereal SOCKS Protocol Dissector Heap Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

A remote overflow exists in Ethereal's SOCKS Protocol Dissector. The protocol dissector fails to do proper bounds checking resulting in a heap overflow. With a specially crafted packet injected into a network being monitored or a file being loaded by Ethereal, an attacker can cause Ethereal to crash or possibly execute arbitrary code.

- 时间线

2003-11-03 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.16 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Disable the SOCKS Protocol Dissector via the Edit->Protocols menu.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站