CVE-2003-0901
CVSS7.5
发布时间 :2003-11-03 00:00:00
修订时间 :2008-09-05 16:35:32
NMCOS    

[原文]Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.


[CNNVD]PostgreSQL To_Ascii()缓冲区溢出漏洞(CNNVD-200311-004)

        
        PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。
        PostgreSQL包含的to_ascii()函数存在问题,远程攻击者可以利用这个漏洞触发缓冲区溢出,可能以PostgreSQL进程权限在系统上执行任意指令。
        提交超多数据给to_ascii()函数,由于缺少充分的缓冲区边界检查,可导致发生基于堆的溢出,通过精心覆盖堆的管理结构可导致以PostgreSQL进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:postgresql:postgresql:7.3.1
cpe:/a:postgresql:postgresql:7.2.1
cpe:/a:postgresql:postgresql:7.3.2
cpe:/a:postgresql:postgresql:7.2 PostgreSQL 7.2
cpe:/a:postgresql:postgresql:7.3 PostgreSQL 7.3
cpe:/a:postgresql:postgresql:7.2.3
cpe:/a:postgresql:postgresql:7.2.2
cpe:/a:postgresql:postgresql:7.2.4
cpe:/a:postgresql:postgresql:7.3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0901
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0901
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-004
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/8741
(VENDOR_ADVISORY)  BID  8741
http://www.redhat.com/support/errata/RHSA-2003-314.html
(UNKNOWN)  REDHAT  RHSA-2003:314
http://www.redhat.com/support/errata/RHSA-2003-313.html
(UNKNOWN)  REDHAT  RHSA-2003:313
http://www.debian.org/security/2003/dsa-397
(UNKNOWN)  DEBIAN  DSA-397
http://developer.postgresql.org/cvsweb.cgi/pgsql-server/src/backend/utils/adt/ascii.c
(UNKNOWN)  CONFIRM  http://developer.postgresql.org/cvsweb.cgi/pgsql-server/src/backend/utils/adt/ascii.c
http://distro.conectiva.com.br/atualizacoes/index.php?id=a&anuncio=000772
(UNKNOWN)  CONECTIVA  CLSA-2003:772
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000784
(UNKNOWN)  CONECTIVA  CLA-2003:784

- 漏洞信息

PostgreSQL To_Ascii()缓冲区溢出漏洞
高危 边界条件错误
2003-11-03 00:00:00 2005-10-20 00:00:00
远程  
        
        PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。
        PostgreSQL包含的to_ascii()函数存在问题,远程攻击者可以利用这个漏洞触发缓冲区溢出,可能以PostgreSQL进程权限在系统上执行任意指令。
        提交超多数据给to_ascii()函数,由于缺少充分的缓冲区边界检查,可导致发生基于堆的溢出,通过精心覆盖堆的管理结构可导致以PostgreSQL进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        PostgreSQL
        ----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.postgresql.org

- 漏洞信息

8776
PostgreSQL to_ascii() Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2003-11-12 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PostgreSQL To_Ascii() Buffer Overflow Vulnerability
Boundary Condition Error 8741
Yes No
2003-08-24 12:00:00 2009-07-11 11:56:00
Discovery of this vulnerability has been credited to Tom Lane.

- 受影响的程序版本

Turbolinux Turbolinux Desktop 10.0
SGI ProPack 2.3
SGI ProPack 2.2.1
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 2.1
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 2.1
PostgreSQL PostgreSQL 7.3.3
+ OpenPKG OpenPKG Current
PostgreSQL PostgreSQL 7.3.2
+ Conectiva Linux 9.0
PostgreSQL PostgreSQL 7.3.1
+ OpenPKG OpenPKG 1.2
PostgreSQL PostgreSQL 7.3
PostgreSQL PostgreSQL 7.2.4
+ RedHat Linux 8.0
+ RedHat Linux 7.3
PostgreSQL PostgreSQL 7.2.3
PostgreSQL PostgreSQL 7.2.2
+ Mandriva Linux Mandrake 9.0
+ Turbolinux Turbolinux Server 8.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
PostgreSQL PostgreSQL 7.2.1
+ Conectiva Linux 8.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux 0.7
+ Gentoo Linux 0.5
PostgreSQL PostgreSQL 7.2
+ Mandriva Linux Mandrake 8.2 ppc
+ Mandriva Linux Mandrake 8.2
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
PostgreSQL PostgreSQL 7.1.3
+ Conectiva Linux 7.0
+ RedHat Linux 7.2
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3 i386
+ S.u.S.E. Linux 7.3
+ Trustix Secure Linux 1.5
+ Trustix Secure Linux 1.2
+ Trustix Secure Linux 1.1
PostgreSQL PostgreSQL 7.3.4
+ OpenPKG OpenPKG Current

- 不受影响的程序版本

PostgreSQL PostgreSQL 7.3.4
+ OpenPKG OpenPKG Current

- 漏洞讨论

PostgreSQL is reported prone to a buffer overflow vulnerability, which presents itself in the PostgreSQL to_ascii() function. The to_ascii() function is normally used to convert text from multibyte encoding format to ASCII.

It has been conjectured that excessive data passed to the to_ascii() function may overrun the bounds of an insufficient buffer reserved in heap based memory. This may result in the corruption of heap based memory management structures that are adjacent to the affected buffer. Although unconfirmed, it is currently believed that under the correct circumstances an attacker may leverage this condition to execute arbitrary instructions in the context of the affected service.

Other ADT (abstract data type) to_ascii_xxx() conversion functions are similarly affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Turbolinux have released an advisory (TLSA-2003-62) to address this issue. Users who are potentially affected by this vulnerability are advised to apply relative fixes as soon as possible. Further information regarding obtaining and applying these fixes can be found in the referenced advisory.

Conectiva has released an advisory (CLA-2003:784) that addresses this issue on Conectiva Linux systems. Users who are potentially affected by this vulnerability are advised to apply appropriate fixes as soon as possible. Further information pertaining to applying these fixes can be found in the referenced advisory. Fixes are linked below.

Red Hat has released an advisory (RHSA-2003:314-08) that addresses this issue on Red Hat Enterprise edition Linux. Customers who are potentially affected by this vulnerability are advised to apply appropriate fixes as soon as possible. Customers can download these fixes from the Red Hat network; further information is available in the referenced advisory.

OpenPKG has released an advisory that provides fixes for OpenPKG 1.2 and CURRENT. postgresql-7.3.4-20030725 addresses the issue in CURRENT and postgresql-7.3.1-1.2.4 was released to address the issue in version 1.2. Please see the attached advisory for more details.

Mandrake has released an advisory (MDKSA-2003:102) to address this issue. Please see the attached advisory for details.

Debian has issued an advisory (DSA 397-1) and fixes. The advisory is linked to in the reference section of this record.

Red Hat has released an advisory (RHSA-2003:313-00) that addresses this issue. Users who are potentially affected by this vulnerability are advised to apply appropriate fixes as soon as possible. Information on how to obtain and apply these fixes can be found in the attached advisory.

An advisory has been released for Trustix Secure Linux (TSLSA-2003-0040) that includes updates for this issue. Please see the attached advisory for details on obtaining and applying updates.

SGI has released an advisory (20031101-01-U) pertaining to their ProPack Linux distribution. The advisory has been released in response to a number of RHSA advisories, and includes a patch (Patch 10032) containing updated RPM packages relating to a number of different BIDS.

Patch 10032 can be obtained via the following link:
http://support.sgi.com/

For information regarding how to obtain individual RPM packages included in Patch 10032, please see the attached advisory.

The vendor has released an upgrade to address this issue:


Turbolinux Turbolinux Desktop 10.0

PostgreSQL PostgreSQL 7.1.3

PostgreSQL PostgreSQL 7.2

PostgreSQL PostgreSQL 7.2.1

PostgreSQL PostgreSQL 7.2.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站