CVE-2003-0894
CVSS4.6
发布时间 :2003-11-17 00:00:00
修订时间 :2008-09-10 15:20:53
NMCO    

[原文]Buffer overflow in the (1) oracle and (2) oracleO programs in Oracle 9i Database 9.0.x and 9.2.x before 9.2.0.4 allows local users to execute arbitrary code via a long command line argument.


[CNNVD]Oracle数据库OracleO二进制本地缓冲区溢出漏洞(CNNVD-200311-073)

        
        Oracle Database是一款商业性质大型数据库系统。
        Oracle数据库包含的'oracleO'程序缺少充分缓冲区边界检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以Oralce进程权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:oracle:oracle9i:standard_9.0.1
cpe:/a:oracle:oracle9i:personal_9.0.1
cpe:/a:oracle:oracle9i:personal_9.2.0.4
cpe:/a:oracle:oracle9i:standard_9.0.1.2
cpe:/a:oracle:oracle9i:standard_9.2.0.4
cpe:/a:oracle:oracle9i:standard_9.0.1.3
cpe:/a:oracle:oracle9i:standard_9.0
cpe:/a:oracle:oracle9i:enterprise_9.0.1
cpe:/a:oracle:oracle9i:standard_9.0.2
cpe:/a:oracle:oracle9i:standard_9.0.1.4
cpe:/a:oracle:oracle9i:enterprise_9.2.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0894
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0894
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-073
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/496340
(UNKNOWN)  CERT-VN  VU#496340
http://xforce.iss.net/xforce/xfdb/13451
(UNKNOWN)  XF  oracle-oracleo-binaries-bo(13451)
http://www.securityfocus.com/bid/8845
(UNKNOWN)  BID  8845
http://www.securityfocus.com/bid/8844
(UNKNOWN)  BID  8844
http://securitytracker.com/id?1007956
(UNKNOWN)  SECTRACK  1007956
http://otn.oracle.com/deploy/security/pdf/2003alert59.pdf
(UNKNOWN)  CONFIRM  http://otn.oracle.com/deploy/security/pdf/2003alert59.pdf

- 漏洞信息

Oracle数据库OracleO二进制本地缓冲区溢出漏洞
中危 边界条件错误
2003-11-17 00:00:00 2006-05-01 00:00:00
本地  
        
        Oracle Database是一款商业性质大型数据库系统。
        Oracle数据库包含的'oracleO'程序缺少充分缓冲区边界检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以Oralce进程权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Oracle
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.oracle.com

- 漏洞信息

6688
Oracle oracle Command Line Argument Local Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2003-10-18 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站