CVE-2003-0861
CVSS10.0
发布时间 :2003-11-17 00:00:00
修订时间 :2008-09-10 15:20:45
NMCO    

[原文]Integer overflows in (1) base64_encode and (2) the GD library for PHP before 4.3.3 have unknown impact and unknown attack vectors.


[CNNVD]PHP整数溢出漏洞(CNNVD-200311-048)

        PHP 4.3.3之前版本中的(1) base64_encode 和(2)GD库存在整数溢出漏洞。该漏洞有未知的影响和未知的攻击向量。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:php:4.0.1:patch1
cpe:/a:php:php:4.0.1PHP PHP 4.0.1
cpe:/a:php:php:4.0.3:patch1
cpe:/a:php:php:4.3.1PHP PHP 4.3.1
cpe:/a:php:php:4.0.7:rc2
cpe:/a:php:php:4.2.0PHP PHP 4.2.0
cpe:/a:php:php:4.2.2PHP PHP 4.2.2
cpe:/a:php:php:4.0.7:rc3
cpe:/a:php:php:4.2.1PHP PHP 4.2.1
cpe:/a:php:php:4.0.2PHP PHP 4.0.2
cpe:/a:php:php:4.0.6PHP PHP 4.0.6
cpe:/a:php:php:4.1.2PHP PHP 4.1.2
cpe:/a:php:php:4.0
cpe:/a:php:php:4.1.1PHP PHP 4.1.1
cpe:/a:php:php:4.0.5PHP PHP 4.0.5
cpe:/a:php:php:4.0.7PHP PHP 4.0.7
cpe:/a:php:php:4.2::dev
cpe:/a:php:php:4.0.1:patch2
cpe:/a:php:php:4.3
cpe:/a:php:php:4.0.4PHP PHP 4.0.4
cpe:/a:php:php:4.0.7:rc1
cpe:/a:php:php:4.1.0PHP PHP 4.1.0
cpe:/a:php:php:4.0.3PHP PHP 4.0.3
cpe:/a:php:php:4.2.3PHP PHP 4.2.3
cpe:/a:php:php:4.3.2PHP PHP 4.3.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0861
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0861
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-048
(官方数据源) CNNVD

- 其它链接及资源

http://www.php.net/release_4_3_3.php
(VENDOR_ADVISORY)  CONFIRM  http://www.php.net/release_4_3_3.php
http://www.php.net/ChangeLog-4.php#4.3.3
(UNKNOWN)  CONFIRM  http://www.php.net/ChangeLog-4.php#4.3.3

- 漏洞信息

PHP整数溢出漏洞
危急 缓冲区溢出
2003-11-17 00:00:00 2005-10-20 00:00:00
远程  
        PHP 4.3.3之前版本中的(1) base64_encode 和(2)GD库存在整数溢出漏洞。该漏洞有未知的影响和未知的攻击向量。

- 公告与补丁

        

- 漏洞信息

11667
PHP base64_encode Function Unspecified Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

PHP contains an issue that may allow an attacker to gain elevated privileges. The issue is due to the base64_encode function not properly sanitizing user-supplied input. By passing crafted data to the function, an attacker can trigger an integer overflow and possibly execute arbitrary code.

- 时间线

2003-08-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站